summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ttyrun/ttyrun_2.29.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/ttyrun/ttyrun_2.29.0.bb')
-rw-r--r--meta/recipes-core/ttyrun/ttyrun_2.29.0.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-core/ttyrun/ttyrun_2.29.0.bb b/meta/recipes-core/ttyrun/ttyrun_2.29.0.bb
new file mode 100644
index 0000000000..e0956b9ac6
--- /dev/null
+++ b/meta/recipes-core/ttyrun/ttyrun_2.29.0.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Start the program if the specified terminal device is available."
2DESCRIPTION = "ttyrun is typically used to prevent a respawn through the \
3init(8) program when a terminal is not available."
4HOMEPAGE = "https://github.com/ibm-s390-linux/s390-tools"
5
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=f5118f167b055bfd7c3450803f1847af"
8
9SRC_URI = "git://github.com/ibm-s390-linux/s390-tools;protocol=https;branch=master"
10SRCREV = "d9ce54dee3ac3827e76624352293a83eb05c727e"
11
12S = "${WORKDIR}/git"
13
14EXTRA_OEMAKE = "\
15 V=1 \
16 CC="${CC}" \
17 DISTRELEASE=${PR} \
18 "
19
20# We just want ttyrun and not the rest of s390-utils
21
22do_configure() {
23 oe_runmake -C ${S}/iucvterm/src clean
24}
25
26do_compile() {
27 oe_runmake -C ${S}/iucvterm/src ttyrun
28}
29
30do_install() {
31 install -d ${D}${sbindir}
32 install ${S}/iucvterm/src/ttyrun ${D}${sbindir}
33}