summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/tasks/task-poky-sdk.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/tasks/task-poky-sdk.bb')
-rw-r--r--meta/recipes-core/tasks/task-poky-sdk.bb84
1 files changed, 84 insertions, 0 deletions
diff --git a/meta/recipes-core/tasks/task-poky-sdk.bb b/meta/recipes-core/tasks/task-poky-sdk.bb
new file mode 100644
index 0000000000..021878cf06
--- /dev/null
+++ b/meta/recipes-core/tasks/task-poky-sdk.bb
@@ -0,0 +1,84 @@
1#
2# Copyright (C) 2007 OpenedHand Ltd.
3#
4
5DESCRIPTON = "Software Development Tasks for OpenedHand Poky"
6LICENSE = "MIT"
7DEPENDS = "task-poky"
8PR = "r5"
9
10ALLOW_EMPTY = "1"
11#PACKAGEFUNCS =+ 'generate_sdk_pkgs'
12
13PACKAGES = "\
14 task-poky-sdk \
15 task-poky-sdk-dbg \
16 task-poky-sdk-dev"
17
18RDEPENDS_task-poky-sdk = "\
19 autoconf \
20 automake \
21 binutils \
22 binutils-symlinks \
23 coreutils \
24 cpp \
25 cpp-symlinks \
26 diffutils \
27 gcc \
28 gcc-symlinks \
29 g++ \
30 g++-symlinks \
31 gettext \
32 make \
33 intltool \
34 libstdc++ \
35 libstdc++-dev \
36 libtool \
37 perl-module-re \
38 perl-module-text-wrap \
39 pkgconfig \
40 findutils \
41 quilt \
42 less \
43 distcc"
44
45#python generate_sdk_pkgs () {
46# poky_pkgs = read_pkgdata('task-poky', d)['PACKAGES']
47# pkgs = bb.data.getVar('PACKAGES', d, 1).split()
48# for pkg in poky_pkgs.split():
49# newpkg = pkg.replace('task-poky', 'task-poky-sdk')
50#
51# # for each of the task packages, add a corresponding sdk task
52# pkgs.append(newpkg)
53#
54# # for each sdk task, take the rdepends of the non-sdk task, and turn
55# # that into rrecommends upon the -dev versions of those, not unlike
56# # the package depchain code
57# spkgdata = read_subpkgdata(pkg, d)
58#
59# rdepends = explode_deps(spkgdata.get('RDEPENDS_%s' % pkg) or '')
60# rreclist = []
61#
62# for depend in rdepends:
63# split_depend = depend.split(' (')
64# name = split_depend[0].strip()
65# if packaged('%s-dev' % name, d):
66# rreclist.append('%s-dev' % name)
67# else:
68# deppkgdata = read_subpkgdata(name, d)
69# rdepends2 = explode_deps(deppkgdata.get('RDEPENDS_%s' % name) or '')
70# for depend in rdepends2:
71# split_depend = depend.split(' (')
72# name = split_depend[0].strip()
73# if packaged('%s-dev' % name, d):
74# rreclist.append('%s-dev' % name)
75#
76# oldrrec = bb.data.getVar('RRECOMMENDS_%s' % newpkg, d) or ''
77# bb.data.setVar('RRECOMMENDS_%s' % newpkg, oldrrec + ' ' + ' '.join(rreclist), d)
78# # bb.note('RRECOMMENDS_%s = "%s"' % (newpkg, bb.data.getVar('RRECOMMENDS_%s' % newpkg, d)))
79#
80# # bb.note('pkgs is %s' % pkgs)
81# bb.data.setVar('PACKAGES', ' '.join(pkgs), d)
82#}
83#
84#PACKAGES_DYNAMIC = "task-poky-sdk-*"