summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd-serialgetty.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/systemd/systemd-serialgetty.bb')
-rw-r--r--meta/recipes-core/systemd/systemd-serialgetty.bb10
1 files changed, 4 insertions, 6 deletions
diff --git a/meta/recipes-core/systemd/systemd-serialgetty.bb b/meta/recipes-core/systemd/systemd-serialgetty.bb
index d9347163b5..d67a3c91b4 100644
--- a/meta/recipes-core/systemd/systemd-serialgetty.bb
+++ b/meta/recipes-core/systemd/systemd-serialgetty.bb
@@ -11,6 +11,10 @@ SRC_URI = "file://serial-getty@.service"
11 11
12S = "${WORKDIR}" 12S = "${WORKDIR}"
13 13
14# As this package is tied to systemd, only build it when we're also building systemd.
15inherit distro_features_check
16REQUIRED_DISTRO_FEATURES = "systemd"
17
14do_install() { 18do_install() {
15 if [ ! -z "${SERIAL_CONSOLES}" ] ; then 19 if [ ! -z "${SERIAL_CONSOLES}" ] ; then
16 default_baudrate=`echo "${SERIAL_CONSOLES}" | sed 's/\;.*//'` 20 default_baudrate=`echo "${SERIAL_CONSOLES}" | sed 's/\;.*//'`
@@ -43,10 +47,4 @@ do_install() {
43FILES_${PN} = "${systemd_unitdir}/system/*.service ${sysconfdir}" 47FILES_${PN} = "${systemd_unitdir}/system/*.service ${sysconfdir}"
44PACKAGE_ARCH = "${MACHINE_ARCH}" 48PACKAGE_ARCH = "${MACHINE_ARCH}"
45 49
46# As this package is tied to systemd, only build it when we're also building systemd.
47python () {
48 if not bb.utils.contains ('DISTRO_FEATURES', 'systemd', True, False, d):
49 raise bb.parse.SkipPackage("'systemd' not in DISTRO_FEATURES")
50}
51
52ALLOW_EMPTY_${PN} = "1" 50ALLOW_EMPTY_${PN} = "1"