summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/systemd/systemd-compat-units.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/systemd/systemd-compat-units.bb')
-rw-r--r--meta/recipes-core/systemd/systemd-compat-units.bb15
1 files changed, 8 insertions, 7 deletions
diff --git a/meta/recipes-core/systemd/systemd-compat-units.bb b/meta/recipes-core/systemd/systemd-compat-units.bb
index 361dc1cbb4..c03d97f9c9 100644
--- a/meta/recipes-core/systemd/systemd-compat-units.bb
+++ b/meta/recipes-core/systemd/systemd-compat-units.bb
@@ -2,7 +2,6 @@ SUMMARY = "Enhances systemd compatilibity with existing SysVinit scripts"
2HOMEPAGE = "http://www.freedesktop.org/wiki/Software/systemd" 2HOMEPAGE = "http://www.freedesktop.org/wiki/Software/systemd"
3LICENSE = "MIT" 3LICENSE = "MIT"
4 4
5PR = "r29"
6 5
7PACKAGE_WRITE_DEPS += "systemd-systemctl-native" 6PACKAGE_WRITE_DEPS += "systemd-systemctl-native"
8 7
@@ -12,9 +11,10 @@ inherit features_check
12 11
13INHIBIT_DEFAULT_DEPS = "1" 12INHIBIT_DEFAULT_DEPS = "1"
14 13
15ALLOW_EMPTY_${PN} = "1" 14ALLOW_EMPTY:${PN} = "1"
16 15
17REQUIRED_DISTRO_FEATURES = "systemd" 16REQUIRED_DISTRO_FEATURES += "systemd"
17REQUIRED_DISTRO_FEATURES += "usrmerge"
18 18
19SYSTEMD_DISABLED_SYSV_SERVICES = " \ 19SYSTEMD_DISABLED_SYSV_SERVICES = " \
20 busybox-udhcpc \ 20 busybox-udhcpc \
@@ -25,9 +25,10 @@ SYSTEMD_DISABLED_SYSV_SERVICES = " \
25 syslog.busybox \ 25 syslog.busybox \
26" 26"
27 27
28pkg_postinst_${PN} () { 28pkg_postinst:${PN} () {
29 29
30 cd $D${sysconfdir}/init.d || exit 0 30 test -d $D${sysconfdir}/init.d || exit 0
31 cd $D${sysconfdir}/init.d
31 32
32 echo "Disabling the following sysv scripts: " 33 echo "Disabling the following sysv scripts: "
33 34
@@ -38,7 +39,7 @@ pkg_postinst_${PN} () {
38 fi 39 fi
39 40
40 for i in ${SYSTEMD_DISABLED_SYSV_SERVICES} ; do 41 for i in ${SYSTEMD_DISABLED_SYSV_SERVICES} ; do
41 if [ -e $i -o -e $i.sh ] && ! [ -e $D${sysconfdir}/systemd/system/$i.service -o -e $D${systemd_unitdir}/system/$i.service ] ; then 42 if [ -e $i -o -e $i.sh ] && ! [ -e $D${sysconfdir}/systemd/system/$i.service -o -e $D${systemd_system_unitdir}/$i.service ] ; then
42 echo -n "$i: " 43 echo -n "$i: "
43 systemctl $OPTS mask $i.service 44 systemctl $OPTS mask $i.service
44 fi 45 fi
@@ -46,4 +47,4 @@ pkg_postinst_${PN} () {
46 echo 47 echo
47} 48}
48 49
49RDEPENDS_${PN} = "systemd" 50RDEPENDS:${PN} = "systemd"