summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/seatd/seatd_0.8.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/seatd/seatd_0.8.0.bb')
-rw-r--r--meta/recipes-core/seatd/seatd_0.8.0.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-core/seatd/seatd_0.8.0.bb b/meta/recipes-core/seatd/seatd_0.8.0.bb
new file mode 100644
index 0000000000..df5fe35f98
--- /dev/null
+++ b/meta/recipes-core/seatd/seatd_0.8.0.bb
@@ -0,0 +1,35 @@
1SUMMARY = "A minimal seat management daemon, and a universal seat management library."
2DESCRIPTION = "Seat management takes care of mediating access to shared devices (graphics, input), without requiring the applications needing access to be root."
3HOMEPAGE = "https://git.sr.ht/~kennylevinsen/seatd"
4
5LICENSE = "MIT"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=715a99d2dd552e6188e74d4ed2914d5a"
8
9SRC_URI = "git://git.sr.ht/~kennylevinsen/seatd;protocol=https;branch=master \
10 file://init"
11SRCREV = "3e9ef69f14f630a719dd464f3c90a7932f1c8296"
12S = "${WORKDIR}/git"
13
14inherit meson pkgconfig update-rc.d
15
16# https://www.openwall.com/lists/musl/2020/01/20/3
17CFLAGS:append:libc-musl:powerpc64le = " -Wno-error=overflow"
18
19PACKAGECONFIG ?= " \
20 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
21 libseat-builtin \
22"
23
24PACKAGECONFIG[libseat-builtin] = "-Dlibseat-builtin=enabled,-Dlibseat-builtin=disabled"
25PACKAGECONFIG[systemd] = ",,systemd"
26
27do_install:append() {
28 if [ "${VIRTUAL-RUNTIME_init_manager}" != "systemd" ]; then
29 install -Dm755 ${UNPACKDIR}/init ${D}/${sysconfdir}/init.d/seatd
30 fi
31}
32
33INITSCRIPT_NAME = "seatd"
34INITSCRIPT_PARAMS = "start 9 5 2 . stop 20 0 1 6 ."
35INHIBIT_UPDATERCD_BBCLASS = "${@oe.utils.conditional('VIRTUAL-RUNTIME_init_manager', 'systemd', '1', '', d)}"