summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/psplash/psplash_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/psplash/psplash_git.bb')
-rw-r--r--meta/recipes-core/psplash/psplash_git.bb40
1 files changed, 21 insertions, 19 deletions
diff --git a/meta/recipes-core/psplash/psplash_git.bb b/meta/recipes-core/psplash/psplash_git.bb
index 59e1e3f194..c7b96bc6a7 100644
--- a/meta/recipes-core/psplash/psplash_git.bb
+++ b/meta/recipes-core/psplash/psplash_git.bb
@@ -2,22 +2,21 @@ SUMMARY = "Userspace framebuffer boot logo based on usplash"
2DESCRIPTION = "PSplash is a userspace graphical boot splash screen for mainly embedded Linux devices supporting a 16bpp or 32bpp framebuffer. It has few dependencies (just libc), supports basic images and text and handles rotation. Its visual look is configurable by basic source changes. Also included is a 'client' command utility for sending information to psplash such as boot progress information." 2DESCRIPTION = "PSplash is a userspace graphical boot splash screen for mainly embedded Linux devices supporting a 16bpp or 32bpp framebuffer. It has few dependencies (just libc), supports basic images and text and handles rotation. Its visual look is configurable by basic source changes. Also included is a 'client' command utility for sending information to psplash such as boot progress information."
3HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/psplash" 3HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/psplash"
4SECTION = "base" 4SECTION = "base"
5LICENSE = "GPLv2+" 5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://psplash.h;beginline=1;endline=8;md5=8f232c1e95929eacab37f00900580224" 6LIC_FILES_CHKSUM = "file://psplash.h;beginline=1;endline=8;md5=8f232c1e95929eacab37f00900580224"
7DEPENDS = "gdk-pixbuf-native" 7DEPENDS = "gdk-pixbuf-native"
8 8
9SRCREV = "0a902f7cd875ccf018456451be369f05fa55f962" 9SRCREV = "ecc1913756698d0c87ad8fa10e44b29537f09ad1"
10PV = "0.1+git${SRCPV}" 10PV = "0.1+git"
11PR = "r15"
12 11
13SRC_URI = "git://git.yoctoproject.org/${BPN} \ 12SRC_URI = "git://git.yoctoproject.org/${BPN};branch=master;protocol=https \
14 file://psplash-init \ 13 file://psplash-init \
15 file://psplash-start.service \ 14 file://psplash-start.service \
16 file://psplash-systemd.service \ 15 file://psplash-systemd.service \
17 ${SPLASH_IMAGES}" 16 ${SPLASH_IMAGES}"
18UPSTREAM_CHECK_COMMITS = "1" 17UPSTREAM_CHECK_COMMITS = "1"
19 18
20SPLASH_IMAGES = "file://psplash-poky-img.h;outsuffix=default" 19SPLASH_IMAGES = "file://psplash-poky-img.png;outsuffix=default"
21 20
22python __anonymous() { 21python __anonymous() {
23 oldpkgs = d.getVar("PACKAGES").split() 22 oldpkgs = d.getVar("PACKAGES").split()
@@ -44,7 +43,7 @@ python __anonymous() {
44 pkgs.append(outname) 43 pkgs.append(outname)
45 localpaths.append(flocal) 44 localpaths.append(flocal)
46 45
47 # Set these so that we have less work to do in do_compile and do_install_append 46 # Set these so that we have less work to do in do_compile and do_install:append
48 d.setVar("SPLASH_INSTALL", " ".join(pkgs)) 47 d.setVar("SPLASH_INSTALL", " ".join(pkgs))
49 d.setVar("SPLASH_LOCALPATHS", " ".join(localpaths)) 48 d.setVar("SPLASH_LOCALPATHS", " ".join(localpaths))
50 for p in pkgs: 49 for p in pkgs:
@@ -54,21 +53,24 @@ python __anonymous() {
54 for p in pkgs: 53 for p in pkgs:
55 ep = '%s%s' % (mlprefix, p) 54 ep = '%s%s' % (mlprefix, p)
56 epsplash = '%s%s' % (mlprefix, 'psplash') 55 epsplash = '%s%s' % (mlprefix, 'psplash')
57 d.setVar("FILES_%s" % ep, "${bindir}/%s" % p) 56 d.setVar("FILES:%s" % ep, "${bindir}/%s" % p)
58 d.setVar("ALTERNATIVE_%s" % ep, 'psplash') 57 d.setVar("ALTERNATIVE:%s" % ep, 'psplash')
59 d.setVarFlag("ALTERNATIVE_TARGET_%s" % ep, 'psplash', '${bindir}/%s' % p) 58 d.setVarFlag("ALTERNATIVE_TARGET_%s" % ep, 'psplash', '${bindir}/%s' % p)
60 d.appendVar("RDEPENDS_%s" % ep, " %s" % pn) 59 d.appendVar("RDEPENDS:%s" % ep, " %s" % pn)
61 if p == "psplash-default": 60 if p == "psplash-default":
62 d.appendVar("RRECOMMENDS_%s" % pn, " %s" % ep) 61 d.appendVar("RDEPENDS:%s" % pn, " %s" % ep)
63} 62}
64 63
65S = "${WORKDIR}/git" 64S = "${WORKDIR}/git"
66 65
67inherit autotools pkgconfig update-rc.d update-alternatives systemd 66inherit autotools pkgconfig update-rc.d update-alternatives systemd
68 67
69PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}" 68PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} progress-bar fullscreen"
70 69
71PACKAGECONFIG[systemd] = "--with-systemd,--without-systemd,systemd" 70PACKAGECONFIG[systemd] = "--with-systemd,--without-systemd,systemd"
71PACKAGECONFIG[fullscreen] = "--enable-img-fullscreen"
72PACKAGECONFIG[startup-msg] = ",--disable-startup-msg"
73PACKAGECONFIG[progress-bar] = ",--disable-progress-bar"
72 74
73ALTERNATIVE_PRIORITY = "100" 75ALTERNATIVE_PRIORITY = "100"
74ALTERNATIVE_LINK_NAME[psplash] = "${bindir}/psplash" 76ALTERNATIVE_LINK_NAME[psplash] = "${bindir}/psplash"
@@ -78,7 +80,7 @@ python do_compile () {
78 import subprocess 80 import subprocess
79 81
80 # Build a separate executable for each splash image 82 # Build a separate executable for each splash image
81 workdir = d.getVar('WORKDIR') 83 workdir = d.getVar('UNPACKDIR')
82 convertscript = "%s/make-image-header.sh" % d.getVar('S') 84 convertscript = "%s/make-image-header.sh" % d.getVar('S')
83 destfile = "%s/psplash-poky-img.h" % d.getVar('B') 85 destfile = "%s/psplash-poky-img.h" % d.getVar('B')
84 localfiles = d.getVar('SPLASH_LOCALPATHS').split() 86 localfiles = d.getVar('SPLASH_LOCALPATHS').split()
@@ -98,7 +100,7 @@ python do_compile () {
98 shutil.copyfile("psplash", outputfile) 100 shutil.copyfile("psplash", outputfile)
99} 101}
100 102
101do_install_append() { 103do_install:append() {
102 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then 104 if ${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'true', 'false', d)}; then
103 install -d ${D}${sysconfdir}/init.d/ 105 install -d ${D}${sysconfdir}/init.d/
104 install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash.sh 106 install -m 0755 ${WORKDIR}/psplash-init ${D}${sysconfdir}/init.d/psplash.sh
@@ -109,9 +111,9 @@ do_install_append() {
109 fi 111 fi
110 112
111 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then 113 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
112 install -d ${D}${systemd_unitdir}/system 114 install -d ${D}${systemd_system_unitdir}
113 install -m 644 ${WORKDIR}/psplash-start.service ${D}/${systemd_unitdir}/system 115 install -m 644 ${WORKDIR}/psplash-start.service ${D}/${systemd_system_unitdir}
114 install -m 644 ${WORKDIR}/psplash-systemd.service ${D}/${systemd_unitdir}/system 116 install -m 644 ${WORKDIR}/psplash-systemd.service ${D}/${systemd_system_unitdir}
115 fi 117 fi
116 118
117 install -d ${D}${bindir} 119 install -d ${D}${bindir}
@@ -122,9 +124,9 @@ do_install_append() {
122} 124}
123 125
124SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}" 126SYSTEMD_PACKAGES = "${@bb.utils.contains('DISTRO_FEATURES','systemd','${PN}','',d)}"
125SYSTEMD_SERVICE_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'psplash-start.service psplash-systemd.service', '', d)}" 127SYSTEMD_SERVICE:${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'psplash-start.service psplash-systemd.service', '', d)}"
126 128
127INITSCRIPT_NAME = "psplash.sh" 129INITSCRIPT_NAME = "psplash.sh"
128INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ." 130INITSCRIPT_PARAMS = "start 0 S . stop 20 0 1 6 ."
129 131
130FILES_${PN} += "/mnt" 132FILES:${PN} += "/mnt"