summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/ovmf/ovmf-shell-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/ovmf/ovmf-shell-image.bb')
-rw-r--r--meta/recipes-core/ovmf/ovmf-shell-image.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-core/ovmf/ovmf-shell-image.bb b/meta/recipes-core/ovmf/ovmf-shell-image.bb
new file mode 100644
index 0000000000..029547b94a
--- /dev/null
+++ b/meta/recipes-core/ovmf/ovmf-shell-image.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "boot image with UEFI shell and tools"
2
3# For this image recipe, only the wic format with a
4# single vfat partition makes sense.
5IMAGE_FSTYPES_forcevariable = 'wic'
6
7WKS_FILE = "ovmf/ovmf-shell-image.wks"
8inherit image
9
10# We want a minimal image with just ovmf-shell-efi unpacked in it. We
11# avoid installing unnecessary stuff as much as possible, but some
12# things still get through and need to be removed.
13PACKAGE_INSTALL = "ovmf-shell-efi"
14LINGUAS_INSTALL = ""
15do_image () {
16 rm -rf `ls -d ${IMAGE_ROOTFS}/* | grep -v efi`
17}