summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/musl/musl-locales_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/musl/musl-locales_git.bb')
-rw-r--r--meta/recipes-core/musl/musl-locales_git.bb85
1 files changed, 85 insertions, 0 deletions
diff --git a/meta/recipes-core/musl/musl-locales_git.bb b/meta/recipes-core/musl/musl-locales_git.bb
new file mode 100644
index 0000000000..1373c60daf
--- /dev/null
+++ b/meta/recipes-core/musl/musl-locales_git.bb
@@ -0,0 +1,85 @@
1# Copyright (C) 2022 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3#
4SUMMARY = "Locales support for musl"
5HOMEPAGE = "https://git.adelielinux.org/adelie/musl-locales/-/wikis/home"
6LICENSE = "MIT & LGPL-3.0-or-later"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=cf5713fba707073020b1db2acaa73e78 \
8 file://LICENSE.MIT;md5=a4f1c6864a83ddf4b754cdab7d593523"
9
10SRC_URI = "git://git.adelielinux.org/adelie/musl-locales;protocol=https;branch=main"
11
12PV = "1.0+git"
13SRCREV = "5663f5bfd30bf9e1e0ba3fc5fe2da6725969f30e"
14
15S = "${WORKDIR}/git"
16
17DEPENDS = "virtual/libintl gettext-native"
18
19PROVIDES = "virtual/libc-locale"
20
21inherit cmake
22
23# We will skip parsing for non-musl systems
24python () {
25 if d.getVar('TCLIBC') != "musl":
26 raise bb.parse.SkipRecipe("Only use it with Musl C library")
27}
28
29# only locale binaries are under GPL-3.0-or-later others are MIT
30LICENSE:${PN} = "LGPL-3.0-or-later"
31LICENSE:locale-base-cs-cz = "MIT"
32LICENSE:locale-base-de-ch = "MIT"
33LICENSE:locale-base-de-de = "MIT"
34LICENSE:locale-base-en-gb = "MIT"
35LICENSE:locale-base-en-us = "MIT"
36LICENSE:locale-base-es-es = "MIT"
37LICENSE:locale-base-fi-fi = "MIT"
38LICENSE:locale-base-fr-ca = "MIT"
39LICENSE:locale-base-fr-fr = "MIT"
40LICENSE:locale-base-it-it = "MIT"
41LICENSE:locale-base-nb-no = "MIT"
42LICENSE:locale-base-nl-nl = "MIT"
43LICENSE:locale-base-pt-br = "MIT"
44LICENSE:locale-base-pt-pt = "MIT"
45LICENSE:locale-base-ru-ru = "MIT"
46LICENSE:locale-base-sr-rs = "MIT"
47LICENSE:locale-base-sv-se = "MIT"
48
49PACKAGES =+ "locale-base-cs-cz \
50 locale-base-de-ch \
51 locale-base-de-de \
52 locale-base-en-gb \
53 locale-base-en-us \
54 locale-base-es-es \
55 locale-base-fi-fi \
56 locale-base-fr-ca \
57 locale-base-fr-fr \
58 locale-base-it-it \
59 locale-base-nb-no \
60 locale-base-nl-nl \
61 locale-base-pt-br \
62 locale-base-pt-pt \
63 locale-base-ru-ru \
64 locale-base-sr-rs \
65 locale-base-sv-se \
66 "
67FILES:locale-base-cs-cz += "${datadir}/i18n/locales/musl/cs_CZ.UTF-8"
68FILES:locale-base-de-ch += "${datadir}/i18n/locales/musl/de_CH.UTF-8"
69FILES:locale-base-de-de += "${datadir}/i18n/locales/musl/de_DE.UTF-8"
70FILES:locale-base-en-gb += "${datadir}/i18n/locales/musl/en_GB.UTF-8"
71FILES:locale-base-en-us += "${datadir}/i18n/locales/musl/en_US.UTF-8"
72FILES:locale-base-es-es += "${datadir}/i18n/locales/musl/es_ES.UTF-8"
73FILES:locale-base-fi-fi += "${datadir}/i18n/locales/musl/fi_FI.UTF-8"
74FILES:locale-base-fr-ca += "${datadir}/i18n/locales/musl/fr_CA.UTF-8"
75FILES:locale-base-fr-fr += "${datadir}/i18n/locales/musl/fr_FR.UTF-8"
76FILES:locale-base-it-it += "${datadir}/i18n/locales/musl/it_IT.UTF-8"
77FILES:locale-base-nb-no += "${datadir}/i18n/locales/musl/nb_NO.UTF-8"
78FILES:locale-base-nl-nl += "${datadir}/i18n/locales/musl/nl_NL.UTF-8"
79FILES:locale-base-pt-br += "${datadir}/i18n/locales/musl/pt_BR.UTF-8"
80FILES:locale-base-pt-pt += "${datadir}/i18n/locales/musl/pt_PT.UTF-8"
81FILES:locale-base-ru-ru += "${datadir}/i18n/locales/musl/ru_RU.UTF-8"
82FILES:locale-base-sr-rs += "${datadir}/i18n/locales/musl/sr_RS.UTF-8"
83FILES:locale-base-sv-se += "${datadir}/i18n/locales/musl/sv_SE.UTF-8"
84
85UPSTREAM_CHECK_COMMITS = "1"