summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/musl/musl-legacy-error.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/musl/musl-legacy-error.bb')
-rw-r--r--meta/recipes-core/musl/musl-legacy-error.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-core/musl/musl-legacy-error.bb b/meta/recipes-core/musl/musl-legacy-error.bb
new file mode 100644
index 0000000000..5ce5a233ab
--- /dev/null
+++ b/meta/recipes-core/musl/musl-legacy-error.bb
@@ -0,0 +1,26 @@
1# Copyright (C) 2023 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "error API GNU extention implementation"
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://error.h;beginline=1;md5=2ee396b23e8507fbf8f98af0471a77c6"
7SECTION = "devel"
8
9SRC_URI = "file://error.h"
10
11do_configure[noexec] = "1"
12do_compile[noexec] = "1"
13
14INHIBIT_DEFAULT_DEPS = "1"
15
16S = "${WORKDIR}"
17
18do_install() {
19 install -Dm 0644 ${S}/error.h -t ${D}${includedir}
20}
21#
22# We will skip parsing for non-musl systems
23#
24COMPATIBLE_HOST = ".*-musl.*"
25DEV_PKG_DEPENDENCY = ""
26RRECOMMENDS:${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"