summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/musl/libc-test_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/musl/libc-test_git.bb')
-rw-r--r--meta/recipes-core/musl/libc-test_git.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/meta/recipes-core/musl/libc-test_git.bb b/meta/recipes-core/musl/libc-test_git.bb
new file mode 100644
index 0000000000..619a959fd2
--- /dev/null
+++ b/meta/recipes-core/musl/libc-test_git.bb
@@ -0,0 +1,57 @@
1SUMMARY = "Musl libc unit tests"
2HOMEPAGE = "https://wiki.musl-libc.org/libc-test.html"
3DESCRIPTION = "libc-test is a collection of unit tests to measure the \
4correctness and robustness of a C/POSIX standard library implementation. It is \
5developed as part of the musl project."
6SECTION = "tests"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=43ed1245085be90dc934288117d55a3b"
9
10inherit ptest
11
12SRCREV = "18e28496adee3d84fefdda6efcb9c5b8996a2398"
13SRC_URI = " \
14 git://repo.or.cz/libc-test;branch=master;protocol=https \
15 file://run-ptest \
16 file://run-libc-ptests \
17"
18
19PV = "0+git"
20
21S = "${WORKDIR}/git"
22
23# libc-test 'make' or 'make run' command is designed to build and run tests. It
24# reports both build and test failures. The commands should be run on target.
25do_compile() {
26 :
27}
28
29RDEPENDS:${PN} = " \
30 bash \
31 grep \
32 musl \
33 packagegroup-core-buildessential \
34"
35
36RDEPENDS:${PN}-ptest = " \
37 ${PN} \
38 musl-staticdev \
39 sed \
40"
41
42install_path = "/opt/${PN}"
43FILES:${PN} += "${install_path}/*"
44
45do_install () {
46 install -d ${D}${install_path}/
47 cp ${S}/Makefile ${D}${install_path}
48 cp ${S}/config.mak.def ${D}${install_path}/config.mak
49 cp -r ${S}/src ${D}${install_path}
50}
51
52do_install_ptest_base:append() {
53 install -Dm 0755 ${WORKDIR}/run-libc-ptests ${D}${PTEST_PATH}/run-libc-ptests
54}
55
56COMPATIBLE_HOST = "null"
57COMPATIBLE_HOST:libc-musl = "(.*)"