summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/testexport-tarball.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/meta/testexport-tarball.bb')
-rw-r--r--meta/recipes-core/meta/testexport-tarball.bb9
1 files changed, 4 insertions, 5 deletions
diff --git a/meta/recipes-core/meta/testexport-tarball.bb b/meta/recipes-core/meta/testexport-tarball.bb
index daedd78cb4..abdd009252 100644
--- a/meta/recipes-core/meta/testexport-tarball.bb
+++ b/meta/recipes-core/meta/testexport-tarball.bb
@@ -4,7 +4,7 @@ DESCRIPTION = "SDK type target for standalone tarball containing packages define
4SUMMARY = "Standalone tarball for test systems with missing software" 4SUMMARY = "Standalone tarball for test systems with missing software"
5LICENSE = "MIT" 5LICENSE = "MIT"
6 6
7TEST_EXPORT_SDK_PACKAGES ??= "" 7require conf/testexport.conf
8 8
9TOOLCHAIN_TARGET_TASK ?= "" 9TOOLCHAIN_TARGET_TASK ?= ""
10 10
@@ -26,7 +26,6 @@ RDEPENDS = "${TOOLCHAIN_HOST_TASK}"
26 26
27EXCLUDE_FROM_WORLD = "1" 27EXCLUDE_FROM_WORLD = "1"
28 28
29inherit meta
30inherit populate_sdk 29inherit populate_sdk
31inherit toolchain-scripts-base 30inherit toolchain-scripts-base
32inherit nopackages 31inherit nopackages
@@ -38,7 +37,7 @@ do_populate_sdk[stamp-extra-info] = "${PACKAGE_ARCH}"
38 37
39REAL_MULTIMACH_TARGET_SYS = "none" 38REAL_MULTIMACH_TARGET_SYS = "none"
40 39
41create_sdk_files_append () { 40create_sdk_files:append () {
42 rm -f ${SDK_OUTPUT}/${SDKPATH}/site-config-* 41 rm -f ${SDK_OUTPUT}/${SDKPATH}/site-config-*
43 rm -f ${SDK_OUTPUT}/${SDKPATH}/environment-setup-* 42 rm -f ${SDK_OUTPUT}/${SDKPATH}/environment-setup-*
44 rm -f ${SDK_OUTPUT}/${SDKPATH}/version-* 43 rm -f ${SDK_OUTPUT}/${SDKPATH}/version-*
@@ -58,8 +57,8 @@ create_sdk_files_append () {
58 57
59 if [ "${SDKMACHINE}" = "i686" ]; then 58 if [ "${SDKMACHINE}" = "i686" ]; then
60 echo 'export NO32LIBS="0"' >>$script 59 echo 'export NO32LIBS="0"' >>$script
61 echo 'echo "$BB_ENV_EXTRAWHITE" | grep -q "NO32LIBS"' >>$script 60 echo 'echo "$BB_ENV_PASSTHROUGH_ADDITIONS" | grep -q "NO32LIBS"' >>$script
62 echo '[ $? != 0 ] && export BB_ENV_EXTRAWHITE="NO32LIBS $BB_ENV_EXTRAWHITE"' >>$script 61 echo '[ $? != 0 ] && export BB_ENV_PASSTHROUGH_ADDITIONS="NO32LIBS $BB_ENV_PASSTHROUGH_ADDITIONS"' >>$script
63 fi 62 fi
64} 63}
65 64