summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/meta-ide-support.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/meta/meta-ide-support.bb')
-rw-r--r--meta/recipes-core/meta/meta-ide-support.bb33
1 files changed, 29 insertions, 4 deletions
diff --git a/meta/recipes-core/meta/meta-ide-support.bb b/meta/recipes-core/meta/meta-ide-support.bb
index 768f6f4bb6..d85aa120c0 100644
--- a/meta/recipes-core/meta/meta-ide-support.bb
+++ b/meta/recipes-core/meta/meta-ide-support.bb
@@ -2,14 +2,39 @@ SUMMARY = "Integrated Development Environment support"
2DESCRIPTION = "Meta package for ensuring the build directory contains all appropriate toolchain packages for using an IDE" 2DESCRIPTION = "Meta package for ensuring the build directory contains all appropriate toolchain packages for using an IDE"
3LICENSE = "MIT" 3LICENSE = "MIT"
4 4
5DEPENDS = "virtual/libc gdb-cross-${TARGET_ARCH} qemu-native qemu-helper-native unfs3-native cmake-native" 5DEPENDS = "virtual/libc gdb-cross-${TARGET_ARCH} qemu-native qemu-helper-native unfs3-native cmake-native autoconf-native automake-native meson-native intltool-native pkgconfig-native"
6PR = "r3"
7RM_WORK_EXCLUDE += "${PN}" 6RM_WORK_EXCLUDE += "${PN}"
8 7
9inherit meta toolchain-scripts nopackages 8inherit toolchain-scripts nopackages deploy testsdk
9
10TESTSDK_CLASS_NAME = "oeqa.sdk.testmetaidesupport.TestSDK"
10 11
11do_populate_ide_support () { 12do_populate_ide_support () {
12 toolchain_create_tree_env_script 13 toolchain_create_tree_env_script
13} 14}
14 15
15addtask populate_ide_support before do_build after do_install 16python () {
17 sitefiles, searched = siteinfo_get_files(d, sysrootcache=False)
18 d.setVar("CONFIG_SITE", " ".join(sitefiles))
19 d.appendVarFlag("do_populate_ide_support", "file-checksums", " " + " ".join(searched))
20}
21
22addtask populate_ide_support before do_deploy after do_install
23
24python do_write_test_data() {
25 from oe.data import export2json
26
27 out_dir = d.getVar('B')
28 testdata_name = os.path.join(out_dir, "%s.testdata.json" % d.getVar('PN'))
29
30 export2json(d, testdata_name)
31}
32addtask write_test_data before do_deploy after do_install
33
34do_deploy () {
35 install ${B}/* ${DEPLOYDIR}
36}
37
38addtask deploy before do_build
39
40do_build[deptask] += "do_prepare_recipe_sysroot"