summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/cve-update-db-native.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/meta/cve-update-db-native.bb')
-rw-r--r--meta/recipes-core/meta/cve-update-db-native.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta/recipes-core/meta/cve-update-db-native.bb b/meta/recipes-core/meta/cve-update-db-native.bb
index c8c1cbf115..18af89b53e 100644
--- a/meta/recipes-core/meta/cve-update-db-native.bb
+++ b/meta/recipes-core/meta/cve-update-db-native.bb
@@ -15,6 +15,7 @@ deltask do_populate_sysroot
15NVDCVE_URL ?= "https://nvd.nist.gov/feeds/json/cve/1.1/nvdcve-1.1-" 15NVDCVE_URL ?= "https://nvd.nist.gov/feeds/json/cve/1.1/nvdcve-1.1-"
16# CVE database update interval, in seconds. By default: once a day (24*60*60). 16# CVE database update interval, in seconds. By default: once a day (24*60*60).
17# Use 0 to force the update 17# Use 0 to force the update
18# Use a negative value to skip the update
18CVE_DB_UPDATE_INTERVAL ?= "86400" 19CVE_DB_UPDATE_INTERVAL ?= "86400"
19 20
20python () { 21python () {
@@ -51,8 +52,9 @@ python do_fetch() {
51 try: 52 try:
52 import time 53 import time
53 update_interval = int(d.getVar("CVE_DB_UPDATE_INTERVAL")) 54 update_interval = int(d.getVar("CVE_DB_UPDATE_INTERVAL"))
54 if (update_interval < 0): 55 if update_interval < 0:
55 update_interval = 0 56 bb.note("CVE database update skipped")
57 return
56 if time.time() - os.path.getmtime(db_file) < update_interval: 58 if time.time() - os.path.getmtime(db_file) < update_interval:
57 bb.debug(2, "Recently updated, skipping") 59 bb.debug(2, "Recently updated, skipping")
58 return 60 return