summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/meta/buildtools-tarball.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/meta/buildtools-tarball.bb')
-rw-r--r--meta/recipes-core/meta/buildtools-tarball.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/buildtools-tarball.bb b/meta/recipes-core/meta/buildtools-tarball.bb
new file mode 100644
index 0000000000..302510c798
--- /dev/null
+++ b/meta/recipes-core/meta/buildtools-tarball.bb
@@ -0,0 +1,55 @@
1DESCRIPTION = "SDK type target for building a standalone tarball containing python, chrpath, make, git and tar. The \
2 tarball can be used to run bitbake builds on systems which don't meet the usual version requirements."
3SUMMARY = "Standalone tarball for running builds on systems with inadequate software"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
6 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8TOOLCHAIN_TARGET_TASK ?= ""
9
10TOOLCHAIN_HOST_TASK ?= "\
11 nativesdk-python-core \
12 nativesdk-python-modules \
13 nativesdk-python-misc \
14 nativesdk-python-git \
15 nativesdk-ncurses-terminfo-base \
16 nativesdk-chrpath \
17 nativesdk-tar \
18 nativesdk-buildtools-perl-dummy \
19 nativesdk-git \
20 nativesdk-git-perltools \
21 nativesdk-pigz \
22 nativesdk-make \
23 nativesdk-wget \
24 nativesdk-ca-certificates \
25 "
26
27SDK_PACKAGE_ARCHS =+ "buildtools-dummy-${SDKPKGSUFFIX}"
28
29TOOLCHAIN_OUTPUTNAME ?= "${SDK_NAME}-buildtools-nativesdk-standalone-${DISTRO_VERSION}"
30
31RDEPENDS = "${TOOLCHAIN_HOST_TASK}"
32
33EXCLUDE_FROM_WORLD = "1"
34
35inherit meta
36inherit populate_sdk
37
38create_sdk_files_append () {
39 rm -f ${SDK_OUTPUT}/${SDKPATH}/site-config-*
40 rm -f ${SDK_OUTPUT}/${SDKPATH}/environment-setup-*
41 rm -f ${SDK_OUTPUT}/${SDKPATH}/version-*
42
43 # Generate new (mini) sdk-environment-setup file
44 script=${1:-${SDK_OUTPUT}/${SDKPATH}/environment-setup-${SDK_SYS}}
45 touch $script
46 echo 'export PATH=${SDKPATHNATIVE}${bindir_nativesdk}:$PATH' >> $script
47 # In order for the self-extraction script to correctly extract and set up things,
48 # we need a 'OECORE_NATIVE_SYSROOT=xxx' line in environment setup script.
49 # However, buildtools-tarball is inherently a tool set instead of a fully functional SDK,
50 # so instead of exporting the variable, we use a comment here.
51 echo '#OECORE_NATIVE_SYSROOT="${SDKPATHNATIVE}"' >> $script
52 toolchain_create_sdk_version ${SDK_OUTPUT}/${SDKPATH}/version-${SDK_SYS}
53
54 echo 'export GIT_SSL_CAINFO="${SDKPATHNATIVE}${sysconfdir}/ssl/certs/ca-certificates.crt"' >>$script
55}