summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxml/libxml2_2.12.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/libxml/libxml2_2.12.6.bb')
-rw-r--r--meta/recipes-core/libxml/libxml2_2.12.6.bb101
1 files changed, 101 insertions, 0 deletions
diff --git a/meta/recipes-core/libxml/libxml2_2.12.6.bb b/meta/recipes-core/libxml/libxml2_2.12.6.bb
new file mode 100644
index 0000000000..14fcff7fa4
--- /dev/null
+++ b/meta/recipes-core/libxml/libxml2_2.12.6.bb
@@ -0,0 +1,101 @@
1SUMMARY = "XML C Parser Library and Toolkit"
2DESCRIPTION = "The XML Parser Library allows for manipulation of XML files. Libxml2 exports Push and Pull type parser interfaces for both XML and HTML. It can do DTD validation at parse time, on a parsed document instance or with an arbitrary DTD. Libxml2 includes complete XPath, XPointer and Xinclude implementations. It also has a SAX like interface, which is designed to be compatible with Expat."
3HOMEPAGE = "https://gitlab.gnome.org/GNOME/libxml2"
4BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml2"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://Copyright;md5=fec7ecfe714722b2bb0aaff7d200c701 \
8 file://dict.c;beginline=6;endline=15;md5=2b4b7b827d2d8b080372433c4c9c85b6 \
9 file://list.c;beginline=4;endline=13;md5=b9c25b021ccaf287e50060602d20f3a7 \
10 file://trio.c;beginline=5;endline=14;md5=cd4f61e27f88c1d43df112966b1cd28f \
11 "
12
13DEPENDS = "zlib virtual/libiconv"
14
15GNOMEBASEBUILDCLASS = "autotools"
16inherit gnomebase
17
18SRC_URI += "http://www.w3.org/XML/Test/xmlts20130923.tar;subdir=${BP};name=testtar \
19 file://run-ptest \
20 file://install-tests.patch \
21 "
22
23SRC_URI[archive.sha256sum] = "889c593a881a3db5fdd96cc9318c87df34eb648edfc458272ad46fd607353fbb"
24SRC_URI[testtar.sha256sum] = "c6b2d42ee50b8b236e711a97d68e6c4b5c8d83e69a2be4722379f08702ea7273"
25
26# Disputed as a security issue, but fixed in d39f780
27CVE_STATUS[CVE-2023-45322] = "disputed: issue requires memory allocation to fail"
28
29BINCONFIG = "${bindir}/xml2-config"
30
31PACKAGECONFIG ??= "python \
32 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
33"
34PACKAGECONFIG[python] = "--with-python=${PYTHON},--without-python,python3"
35PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
36
37inherit autotools pkgconfig binconfig-disabled ptest
38
39inherit_defer ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3targetconfig', '', d)}
40
41LDFLAGS:append:riscv64 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-lld ptest', ' -fuse-ld=bfd', '', d)}"
42
43RDEPENDS:${PN}-ptest += "bash make locale-base-en-us ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-logging python3-shell python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"
44
45RDEPENDS:${PN}-python += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3-core', '', d)}"
46
47RDEPENDS:${PN}-ptest:append:libc-musl = " musl-locales"
48RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-gconv-ebcdic-us \
49 glibc-gconv-ibm1141 \
50 glibc-gconv-iso8859-5 \
51 glibc-gconv-euc-jp \
52 "
53
54# WARNING: zlib is required for RPM use
55EXTRA_OECONF = "--without-debug --without-legacy --with-catalog --with-c14n --without-lzma --with-fexceptions"
56EXTRA_OECONF:class-native = "--without-legacy --with-c14n --without-lzma --with-zlib"
57EXTRA_OECONF:class-nativesdk = "--without-legacy --with-c14n --without-lzma --with-zlib"
58EXTRA_OECONF:linuxstdbase = "--with-debug --with-legacy --with-c14n --without-lzma --with-zlib"
59
60python populate_packages:prepend () {
61 # autonamer would call this libxml2-2, but we don't want that
62 if d.getVar('DEBIAN_NAMES'):
63 d.setVar('PKG:libxml2', '${MLPREFIX}libxml2')
64}
65
66PACKAGE_BEFORE_PN += "${PN}-utils"
67PACKAGES += "${PN}-python"
68
69FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
70FILES:${PN}-utils = "${bindir}/*"
71FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
72
73do_configure:prepend () {
74 # executables take longer to package: these should not be executable
75 find ${S}/xmlconf/ -type f -exec chmod -x {} \+
76}
77
78do_install_ptest () {
79 oe_runmake DESTDIR=${D} ptestdir=${PTEST_PATH} install-test-data
80
81 cp -r ${S}/xmlconf ${D}${PTEST_PATH}
82
83 if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then
84 rm -rf ${D}${PTEST_DIR}/python
85 fi
86}
87
88# with musl we need to enable icu support explicitly for these tests
89do_install_ptest:append:libc-musl () {
90 rm -rf ${D}/${PTEST_PATH}/test/icu_parse_test.xml
91}
92
93do_install:append:class-native () {
94 # Docs are not needed in the native case
95 rm ${D}${datadir}/gtk-doc -rf
96
97 create_wrapper ${D}${bindir}/xmllint 'XML_CATALOG_FILES=${XML_CATALOG_FILES:-${sysconfdir}/xml/catalog}'
98}
99do_install[vardepsexclude] += "XML_CATALOG_FILES:-${sysconfdir}/xml/catalog"
100
101BBCLASSEXTEND = "native nativesdk"