summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb')
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb34
1 files changed, 1 insertions, 33 deletions
diff --git a/meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb b/meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb
index 1787f6921e..aba9b1ef0c 100644
--- a/meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb
+++ b/meta/recipes-core/libxcrypt/libxcrypt_4.4.8.bb
@@ -1,33 +1 @@
1SUMMARY = "Extended cryptographic library (from glibc)" require libxcrypt.inc
2DESCRIPTION = "Forked code from glibc libary to extract only crypto part."
3HOMEPAGE = "https://github.com/besser82/libxcrypt"
4SECTION = "libs"
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM ?= "file://LICENSING;md5=3bb6614cf5880cbf1b9dbd9e3d145e2c \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit autotools pkgconfig
11
12SRC_URI = "git://github.com/besser82/libxcrypt.git;branch=${SRCBRANCH}"
13SRCREV = "acd84997a5a8b2badd28b70a642abee11272fad2"
14SRCBRANCH ?= "develop"
15
16PROVIDES = "virtual/crypt"
17
18FILES_${PN} = "${libdir}/libcrypt*.so.* \
19 ${libdir}/libcrypt-*.so \
20 ${libdir}/libowcrypt*.so.* \
21 ${libdir}/libowcrypt-*.so \
22"
23
24S = "${WORKDIR}/git"
25
26BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
27TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir} -Wno-error"
28CPPFLAGS_append_class-nativesdk = " -Wno-error"
29
30API = "--disable-obsolete-api"
31EXTRA_OECONF += "${API}"
32
33BBCLASSEXTEND = "nativesdk"