summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb')
-rw-r--r--meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb b/meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb
new file mode 100644
index 0000000000..637c0e6ffb
--- /dev/null
+++ b/meta/recipes-core/libxcrypt/libxcrypt_4.4.6.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Extended cryptographic library (from glibc)"
2DESCRIPTION = "Forked code from glibc libary to extract only crypto part."
3HOMEPAGE = "https://github.com/besser82/libxcrypt"
4SECTION = "libs"
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM ?= "file://LICENSING;md5=be275bc7f91642efe7709a8ae7a1433b \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10inherit autotools pkgconfig
11
12PV = "4.4.6"
13
14SRC_URI = "git://github.com/besser82/libxcrypt.git;branch=${SRCBRANCH}"
15SRCREV = "398943774c5ff38baf1bc5ee088855fd8983bb05"
16SRCBRANCH ?= "develop"
17
18PROVIDES = "virtual/crypt"
19
20FILES_${PN} = "${libdir}/libcrypt*.so.* \
21 ${libdir}/libcrypt-*.so \
22 ${libdir}/libowcrypt*.so.* \
23 ${libdir}/libowcrypt-*.so \
24"
25
26S = "${WORKDIR}/git"
27
28BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
29TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir} -Wno-error=missing-attributes"
30CPPFLAGS_append_class-nativesdk = " -Wno-error=missing-attributes"
31
32BBCLASSEXTEND = "nativesdk"