summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/libcgroup/libcgroup_2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/libcgroup/libcgroup_2.0.bb')
-rw-r--r--meta/recipes-core/libcgroup/libcgroup_2.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-core/libcgroup/libcgroup_2.0.bb b/meta/recipes-core/libcgroup/libcgroup_2.0.bb
new file mode 100644
index 0000000000..bc0a75d46c
--- /dev/null
+++ b/meta/recipes-core/libcgroup/libcgroup_2.0.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Linux control group abstraction library"
2HOMEPAGE = "http://libcg.sourceforge.net/"
3DESCRIPTION = "libcgroup is a library that abstracts the control group file system \
4in Linux. Control groups allow you to limit, account and isolate resource usage \
5(CPU, memory, disk I/O, etc.) of groups of processes."
6SECTION = "libs"
7LICENSE = "LGPLv2.1"
8LIC_FILES_CHKSUM = "file://COPYING;md5=2d5025d4aa3495befef8f17206a5b0a1"
9
10inherit autotools pkgconfig
11
12DEPENDS = "bison-native flex-native"
13
14SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.bz2 \
15 file://musl-decls-compat.patch \
16 file://module.patch"
17
18SRC_URI[sha256sum] = "11a2fbf0e42f46089f406b8b0dca7fef04aec2f21600b70e402c5db3661305d7"
19UPSTREAM_CHECK_URI = "https://github.com/libcgroup/libcgroup/releases/"
20
21DEPENDS:append:libc-musl = " fts "
22EXTRA_OEMAKE:append:libc-musl = " LIBS=-lfts"
23
24PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}"
25PACKAGECONFIG[pam] = "--enable-pam-module-dir=${base_libdir}/security --enable-pam=yes,--enable-pam=no,libpam"
26
27PACKAGES =+ "cgroups-pam-plugin"
28FILES:cgroups-pam-plugin = "${base_libdir}/security/pam_cgroup.so*"
29FILES:${PN}-dev += "${base_libdir}/security/*.la"
30
31do_install:append() {
32 # Until we ship the test suite, this library isn't useful
33 rm -f ${D}${libdir}/libcgroupfortesting.*
34}