summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/kbd/kbd_2.6.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/kbd/kbd_2.6.4.bb')
-rw-r--r--meta/recipes-core/kbd/kbd_2.6.4.bb67
1 files changed, 67 insertions, 0 deletions
diff --git a/meta/recipes-core/kbd/kbd_2.6.4.bb b/meta/recipes-core/kbd/kbd_2.6.4.bb
new file mode 100644
index 0000000000..2331b51e59
--- /dev/null
+++ b/meta/recipes-core/kbd/kbd_2.6.4.bb
@@ -0,0 +1,67 @@
1SUMMARY = "Keytable files and keyboard utilities"
2HOMEPAGE = "http://www.kbd-project.org/"
3DESCRIPTION = "The kbd project contains tools for managing Linux console (Linux console, virtual terminals, keyboard, etc.) – mainly, what they do is loading console fonts and keyboard maps."
4
5# consolefonts and keymaps contain also some public domain and author notice licenses
6LICENSE = "GPL-2.0-or-later & LGPL-2.0-or-later & GPL-3.0-or-later"
7LIC_FILES_CHKSUM = " \
8 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
9 file://data/keymaps/pine/en.map;beginline=2;endline=15;md5=20914a59c0546a7b77ebf959bc88ad5d \
10"
11LICENSE:${PN} = "GPL-2.0-or-later & LGPL-2.0-or-later"
12LICENSE:${PN}-consolefonts = "GPL-2.0-or-later"
13LICENSE:${PN}-consoletrans = "GPL-2.0-or-later"
14LICENSE:${PN}-keymaps-pine = "GPL-3.0-or-later"
15LICENSE:${PN}-keymaps = "GPL-2.0-or-later"
16LICENSE:${PN}-unimaps = "GPL-2.0-or-later"
17
18inherit autotools gettext pkgconfig
19
20DEPENDS += "flex-native"
21
22RREPLACES:${PN} = "console-tools"
23RPROVIDES:${PN} = "console-tools"
24RCONFLICTS:${PN} = "console-tools"
25
26SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/${BP}.tar.xz \
27 file://0001-Remove-non-free-Agafari-fonts.patch \
28 "
29
30SRC_URI[sha256sum] = "519f8d087aecca7e0a33cd084bef92c066eb19731666653dcc70c9d71aa40926"
31
32EXTRA_OECONF = "--disable-tests"
33PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)} \
34 "
35
36PACKAGECONFIG[pam] = "--enable-vlock, --disable-vlock, libpam,"
37
38PACKAGES += "${PN}-consolefonts ${PN}-keymaps-pine ${PN}-keymaps ${PN}-unimaps ${PN}-consoletrans"
39
40FILES:${PN}-consolefonts = "${datadir}/consolefonts"
41FILES:${PN}-consoletrans = "${datadir}/consoletrans"
42FILES:${PN}-keymaps-pine = "${datadir}/keymaps/pine"
43FILES:${PN}-keymaps = "${datadir}/keymaps"
44FILES:${PN}-unimaps = "${datadir}/unimaps"
45
46RRECOMMENDS:${PN}-keymaps = "${PN}-keymaps-pine"
47
48# remove this when upgrading to newer version which has integrated
49# https://github.com/legionus/kbd/commit/b757e6842f9631757f0d1a6b3833aabffa9ffeee
50do_configure:prepend() {
51 rm -rf ${S}/data/consolefonts/Agafari-1*
52}
53
54do_install:append () {
55 if [ "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'yes', 'no', d)}" = "yes" ] \
56 && [ -f ${D}${sysconfdir}/pam.d/vlock ]; then
57 mv -f ${D}${sysconfdir}/pam.d/vlock ${D}${sysconfdir}/pam.d/vlock.kbd
58 fi
59}
60
61inherit update-alternatives
62
63ALTERNATIVE:${PN} = "chvt deallocvt fgconsole openvt showkey \
64 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'vlock','', d)}"
65ALTERNATIVE_PRIORITY = "100"
66
67BBCLASSEXTEND = "native"