summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/initscripts/init-system-helpers_1.57.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/initscripts/init-system-helpers_1.57.bb')
-rw-r--r--meta/recipes-core/initscripts/init-system-helpers_1.57.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-core/initscripts/init-system-helpers_1.57.bb b/meta/recipes-core/initscripts/init-system-helpers_1.57.bb
new file mode 100644
index 0000000000..d41bb94791
--- /dev/null
+++ b/meta/recipes-core/initscripts/init-system-helpers_1.57.bb
@@ -0,0 +1,46 @@
1SUMMARY = "helper tools for all init systems"
2DESCRIPTION = "This package contains helper tools that are necessary for switching between \
3the various init systems that Debian contains (e. g. sysvinit or \
4systemd). An example is deb-systemd-helper, a script that enables systemd unit \
5files without depending on a running systemd. \
6\
7It also includes the \"service\", \"invoke-rc.d\", and \"update-rc.d\" scripts which \
8provide an abstraction for enabling, disabling, starting, and stopping \
9services for all supported Debian init systems as specified by the policy. \
10\
11While this package is maintained by pkg-systemd-maintainers, it is NOT \
12specific to systemd at all. Maintainers of other init systems are welcome to \
13include their helpers in this package."
14HOMEPAGE = "https://salsa.debian.org/debian/init-system-helpers"
15SECTION = "base"
16LICENSE = "BSD-3-Clause & GPLv2"
17LIC_FILES_CHKSUM = "file://debian/copyright;md5=ee2b1830fcfead84d07bc060ec43e072"
18
19DEPENDS = "perl"
20
21SRCREV = "760c625ec0e1ffebec2e391d891d389da0f65726"
22SRC_URI = "git://salsa.debian.org/debian/init-system-helpers.git"
23
24S = "${WORKDIR}/git"
25
26do_configure[noexec] = "1"
27do_compile[noexec] = "1"
28
29do_install() {
30 install -d -m 0755 ${D}${sbindir}
31 install -m 0755 ${S}/script/invoke-rc.d ${D}${sbindir}
32 install -m 0755 ${S}/script/service ${D}${sbindir}
33 install -m 0755 ${S}/script/update-rc.d ${D}${sbindir}
34}
35
36PACKAGES += "${PN}-invoke-rc.d ${PN}-service ${PN}-update-rc.d"
37
38FILES_${PN} = ""
39FILES_${PN}-invoke-rc.d = "${sbindir}/invoke-rc.d"
40FILES_${PN}-service = "${sbindir}/service"
41FILES_${PN}-update-rc.d = "${sbindir}/update-rc.d"
42
43ALLOW_EMPTY_${PN} = "1"
44
45RDEPENDS_${PN}-update-rc.d = "perl"
46RRECOMMENDS_${PN} += "${PN}-invoke-rc.d ${PN}-service ${PN}-update-rc.d"