summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/images/core-image-tiny-initramfs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/images/core-image-tiny-initramfs.bb')
-rw-r--r--meta/recipes-core/images/core-image-tiny-initramfs.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-core/images/core-image-tiny-initramfs.bb b/meta/recipes-core/images/core-image-tiny-initramfs.bb
index 47470849ed..7a71d55b1e 100644
--- a/meta/recipes-core/images/core-image-tiny-initramfs.bb
+++ b/meta/recipes-core/images/core-image-tiny-initramfs.bb
@@ -1,4 +1,5 @@
1# Simple initramfs image artifact generation for tiny images. 1# Simple initramfs image artifact generation for tiny images.
2SUMMARY = "Tiny image capable of booting a device."
2DESCRIPTION = "Tiny image capable of booting a device. The kernel includes \ 3DESCRIPTION = "Tiny image capable of booting a device. The kernel includes \
3the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \ 4the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
4first 'init' program more efficiently. core-image-tiny-initramfs doesn't \ 5first 'init' program more efficiently. core-image-tiny-initramfs doesn't \
@@ -12,7 +13,6 @@ PACKAGE_INSTALL = "initramfs-live-boot-tiny packagegroup-core-boot dropbear ${VI
12# Do not pollute the initrd image with rootfs features 13# Do not pollute the initrd image with rootfs features
13IMAGE_FEATURES = "" 14IMAGE_FEATURES = ""
14 15
15export IMAGE_BASENAME = "core-image-tiny-initramfs"
16IMAGE_NAME_SUFFIX ?= "" 16IMAGE_NAME_SUFFIX ?= ""
17IMAGE_LINGUAS = "" 17IMAGE_LINGUAS = ""
18 18
@@ -27,7 +27,7 @@ IMAGE_ROOTFS_SIZE = "8192"
27IMAGE_ROOTFS_EXTRA_SPACE = "0" 27IMAGE_ROOTFS_EXTRA_SPACE = "0"
28 28
29# Use the same restriction as initramfs-live-install 29# Use the same restriction as initramfs-live-install
30COMPATIBLE_HOST = "(i.86|x86_64|aarch64).*-linux" 30COMPATIBLE_HOST = "(i.86|x86_64|aarch64|arm).*-linux"
31 31
32python tinyinitrd () { 32python tinyinitrd () {
33 # Modify our init file so the user knows we drop to shell prompt on purpose 33 # Modify our init file so the user knows we drop to shell prompt on purpose
@@ -39,6 +39,6 @@ python tinyinitrd () {
39 init.write(newinit) 39 init.write(newinit)
40} 40}
41 41
42IMAGE_PREPROCESS_COMMAND += "tinyinitrd;" 42IMAGE_PREPROCESS_COMMAND += "tinyinitrd"
43 43
44QB_KERNEL_CMDLINE_APPEND += "debugshell=3 init=/bin/busybox sh init" 44QB_KERNEL_CMDLINE_APPEND += "debugshell=3 init=/bin/busybox sh init"