summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/images/core-image-ptest-all.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/images/core-image-ptest-all.bb')
-rw-r--r--meta/recipes-core/images/core-image-ptest-all.bb34
1 files changed, 17 insertions, 17 deletions
diff --git a/meta/recipes-core/images/core-image-ptest-all.bb b/meta/recipes-core/images/core-image-ptest-all.bb
index 1472451675..81c9b2d68a 100644
--- a/meta/recipes-core/images/core-image-ptest-all.bb
+++ b/meta/recipes-core/images/core-image-ptest-all.bb
@@ -1,25 +1,25 @@
1inherit features_check 1DESCRIPTION = "Recipe to trigger execution of all ptest images."
2HOMEPAGE = "https://www.yoctoproject.org/"
3
4LICENSE = "MIT"
5
6inherit features_check nopackages
2REQUIRED_DISTRO_FEATURES = "ptest" 7REQUIRED_DISTRO_FEATURES = "ptest"
3 8
4require core-image-minimal.bb
5require conf/distro/include/ptest-packagelists.inc 9require conf/distro/include/ptest-packagelists.inc
6 10
7DESCRIPTION += "Also includes ptest packages."
8HOMEPAGE = "https://www.yoctoproject.org/"
9
10# Include the full set of ptests 11# Include the full set of ptests
11IMAGE_INSTALL += "${PTESTS_FAST} ${PTESTS_SLOW}" 12PTESTS = "${PTESTS_FAST} ${PTESTS_SLOW}"
13
14do_testimage[noexec] = "1"
15do_testimage[depends] = "${@' '.join(['core-image-ptest-'+x.replace('-ptest', '')+':do_testimage' for x in d.getVar('PTESTS').split()])}"
12 16
13# This image is sufficiently large (~1.8GB) that we need to be careful that it fits in a live 17do_build[depends] = "${@' '.join(['core-image-ptest-'+x.replace('-ptest', '')+':do_build' for x in d.getVar('PTESTS').split()])}"
14# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
15# box) and explicitly add just 1100MB.
16# strace-ptest in particular needs more than 500MB
17IMAGE_OVERHEAD_FACTOR = "1.0"
18IMAGE_ROOTFS_EXTRA_SPACE = "1124288"
19 18
20# ptests need more memory than standard to avoid the OOM killer 19# normally image.bbclass would do this
21# also lttng-tools needs /tmp that has at least 2G 20EXCLUDE_FROM_WORLD = "1"
22QB_MEM = "-m 4096"
23 21
24# Sadly at the moment the full set of ptests is not robust enough and sporadically fails in random places 22python () {
25PTEST_EXPECT_FAILURE = "1" 23 if bb.utils.contains('IMAGE_CLASSES', 'testimage', True, False, d):
24 bb.build.addtask("do_testimage", "", "", d)
25}