summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/images/core-image-initramfs-boot.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/images/core-image-initramfs-boot.bb')
-rw-r--r--meta/recipes-core/images/core-image-initramfs-boot.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-core/images/core-image-initramfs-boot.bb b/meta/recipes-core/images/core-image-initramfs-boot.bb
new file mode 100644
index 0000000000..7258944751
--- /dev/null
+++ b/meta/recipes-core/images/core-image-initramfs-boot.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Basic initramfs to boot a fully-featured rootfs"
2DESCRIPTION = "Small initramfs that contains just udev and init, to find the real rootfs."
3LICENSE = "MIT"
4
5INITRAMFS_SCRIPTS ?= "initramfs-framework-base initramfs-module-udev"
6
7PACKAGE_INSTALL = "${INITRAMFS_SCRIPTS} ${VIRTUAL-RUNTIME_base-utils} base-passwd"
8
9# Ensure the initramfs only contains the bare minimum
10IMAGE_FEATURES = ""
11IMAGE_LINGUAS = ""
12
13# Don't allow the initramfs to contain a kernel, as kernel modules will depend
14# on the kernel image.
15PACKAGE_EXCLUDE = "kernel-image-*"
16
17IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
18IMAGE_NAME_SUFFIX ?= ""
19IMAGE_ROOTFS_SIZE = "8192"
20IMAGE_ROOTFS_EXTRA_SPACE = "0"
21
22inherit image