summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc_2.33.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glibc/glibc_2.33.bb')
-rw-r--r--meta/recipes-core/glibc/glibc_2.33.bb120
1 files changed, 0 insertions, 120 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.33.bb b/meta/recipes-core/glibc/glibc_2.33.bb
deleted file mode 100644
index c47826a51e..0000000000
--- a/meta/recipes-core/glibc/glibc_2.33.bb
+++ /dev/null
@@ -1,120 +0,0 @@
1require glibc.inc
2require glibc-version.inc
3
4CVE_CHECK_WHITELIST += "CVE-2020-10029"
5
6DEPENDS += "gperf-native bison-native make-native"
7
8NATIVESDKFIXES ?= ""
9NATIVESDKFIXES_class-nativesdk = "\
10 file://0003-nativesdk-glibc-Look-for-host-system-ld.so.cache-as-.patch \
11 file://0004-nativesdk-glibc-Fix-buffer-overrun-with-a-relocated-.patch \
12 file://0005-nativesdk-glibc-Raise-the-size-of-arrays-containing-.patch \
13 file://0006-nativesdk-glibc-Allow-64-bit-atomics-for-x86.patch \
14 file://0007-nativesdk-glibc-Make-relocatable-install-for-locales.patch \
15 file://faccessat2-perm.patch \
16"
17
18SRC_URI = "${GLIBC_GIT_URI};branch=${SRCBRANCH};name=glibc \
19 file://etc/ld.so.conf \
20 file://generate-supported.mk \
21 file://makedbs.sh \
22 \
23 ${NATIVESDKFIXES} \
24 file://0008-fsl-e500-e5500-e6500-603e-fsqrt-implementation.patch \
25 file://0009-ppc-sqrt-Fix-undefined-reference-to-__sqrt_finite.patch \
26 file://0010-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
27 file://0011-Quote-from-bug-1443-which-explains-what-the-patch-do.patch \
28 file://0012-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
29 file://0013-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
30 file://0014-sysdeps-gnu-configure.ac-handle-correctly-libc_cv_ro.patch \
31 file://0015-yes-within-the-path-sets-wrong-config-variables.patch \
32 file://0016-timezone-re-written-tzselect-as-posix-sh.patch \
33 file://0017-Remove-bash-dependency-for-nscd-init-script.patch \
34 file://0018-eglibc-Cross-building-and-testing-instructions.patch \
35 file://0019-eglibc-Help-bootstrap-cross-toolchain.patch \
36 file://0020-eglibc-Resolve-__fpscr_values-on-SH4.patch \
37 file://0021-eglibc-Forward-port-cross-locale-generation-support.patch \
38 file://0022-Define-DUMMY_LOCALE_T-if-not-defined.patch \
39 file://0023-localedef-add-to-archive-uses-a-hard-coded-locale-pa.patch \
40 file://0024-elf-dl-deps.c-Make-_dl_build_local_scope-breadth-fir.patch \
41 file://0025-intl-Emit-no-lines-in-bison-generated-files.patch \
42 file://0027-locale-prevent-maybe-uninitialized-errors-with-Os-BZ.patch \
43 file://0028-readlib-Add-OECORE_KNOWN_INTERPRETER_NAMES-to-known-.patch \
44 file://0029-wordsize.h-Unify-the-header-between-arm-and-aarch64.patch \
45 file://0030-powerpc-Do-not-ask-compiler-for-finding-arch.patch \
46 file://0031-x86-Require-full-ISA-support-for-x86-64-level-marker.patch \
47 file://0032-string-Work-around-GCC-PR-98512-in-rawmemchr.patch \
48 "
49S = "${WORKDIR}/git"
50B = "${WORKDIR}/build-${TARGET_SYS}"
51
52PACKAGES_DYNAMIC = ""
53
54# the -isystem in bitbake.conf screws up glibc do_stage
55BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
56TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
57
58GLIBC_BROKEN_LOCALES = ""
59
60GLIBCPIE ??= ""
61
62EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
63 --disable-profile \
64 --disable-debug --without-gd \
65 --enable-clocale=gnu \
66 --with-headers=${STAGING_INCDIR} \
67 --without-selinux \
68 --enable-tunables \
69 --enable-bind-now \
70 --enable-stack-protector=strong \
71 --enable-stackguard-randomization \
72 --disable-crypt \
73 --with-default-link \
74 ${@bb.utils.contains_any('SELECTED_OPTIMIZATION', '-O0 -Og', '--disable-werror', '', d)} \
75 ${GLIBCPIE} \
76 ${GLIBC_EXTRA_OECONF}"
77
78EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
79
80EXTRA_OECONF_append_x86 = " --enable-cet"
81EXTRA_OECONF_append_x86-64 = " --enable-cet"
82
83PACKAGECONFIG ??= "nscd"
84PACKAGECONFIG[nscd] = "--enable-nscd,--disable-nscd"
85
86do_patch_append() {
87 bb.build.exec_func('do_fix_readlib_c', d)
88}
89
90do_fix_readlib_c () {
91 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
92}
93
94do_configure () {
95# override this function to avoid the autoconf/automake/aclocal/autoheader
96# calls for now
97# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
98# version check and doesn't really help with anything
99 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
100 find ${S} -name "configure" | xargs touch
101 CPPFLAGS="" oe_runconf
102}
103
104LDFLAGS += "-fuse-ld=bfd"
105do_compile () {
106 base_do_compile
107 echo "Adjust ldd script"
108 if [ -n "${RTLDLIST}" ]
109 then
110 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
111 # remove duplicate entries
112 newrtld=`echo $(printf '%s\n' ${prevrtld} ${RTLDLIST} | LC_ALL=C sort -u)`
113 echo "ldd \"${prevrtld} ${RTLDLIST}\" -> \"${newrtld}\""
114 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${newrtld}\"#"
115 fi
116}
117
118require glibc-package.inc
119
120BBCLASSEXTEND = "nativesdk"