summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc_2.28.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glibc/glibc_2.28.bb')
-rw-r--r--meta/recipes-core/glibc/glibc_2.28.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.28.bb b/meta/recipes-core/glibc/glibc_2.28.bb
index d072939254..a107c58b9f 100644
--- a/meta/recipes-core/glibc/glibc_2.28.bb
+++ b/meta/recipes-core/glibc/glibc_2.28.bb
@@ -122,10 +122,10 @@ do_compile () {
122 if [ -n "${RTLDLIST}" ] 122 if [ -n "${RTLDLIST}" ]
123 then 123 then
124 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'` 124 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
125 if [ "${prevrtld}" != "${RTLDLIST}" ] 125 # remove duplicate entries
126 then 126 newrtld=`echo $(printf '%s\n' ${prevrtld} ${RTLDLIST} | LC_ALL=C sort -u)`
127 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${prevrtld} ${RTLDLIST}\"#" 127 echo "ldd \"${prevrtld} ${RTLDLIST}\" -> \"${newrtld}\""
128 fi 128 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${newrtld}\"#"
129 fi 129 fi
130 130
131} 131}