summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/glibc_2.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glibc/glibc_2.22.bb')
-rw-r--r--meta/recipes-core/glibc/glibc_2.22.bb139
1 files changed, 139 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/glibc_2.22.bb b/meta/recipes-core/glibc/glibc_2.22.bb
new file mode 100644
index 0000000000..6aaf72260a
--- /dev/null
+++ b/meta/recipes-core/glibc/glibc_2.22.bb
@@ -0,0 +1,139 @@
1require glibc.inc
2
3LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
4 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
5 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
6 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
7
8DEPENDS += "gperf-native kconfig-frontends-native"
9
10SRCREV ?= "a34d1c6afc86521d6ad17662a3b5362d8481514c"
11
12BRANCH ?= "release/${PV}/master"
13
14GLIBC_GIT_URI ?= "git://sourceware.org/git/glibc.git"
15
16SRC_URI = "${GLIBC_GIT_URI};branch=${BRANCH};name=glibc \
17 file://0004-Backport-https-sourceware.org-ml-libc-ports-2007-12-.patch \
18 file://0005-fsl-e500-e5500-e6500-603e-fsqrt-implementation.patch \
19 file://0006-readlib-Add-OECORE_KNOWN_INTERPRETER_NAMES-to-known-.patch \
20 file://0007-ppc-sqrt-Fix-undefined-reference-to-__sqrt_finite.patch \
21 file://0008-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
22 file://0009-Quote-from-bug-1443-which-explains-what-the-patch-do.patch \
23 file://0010-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
24 file://0011-__ieee754_sqrt-f-are-now-inline-functions-and-call-o.patch \
25 file://0012-Make-ld-version-output-matching-grok-gold-s-output.patch \
26 file://0013-sysdeps-gnu-configure.ac-handle-correctly-libc_cv_ro.patch \
27 file://0014-Add-unused-attribute.patch \
28 file://0015-When-disabling-SSE-also-make-sure-that-fpmath-is-not.patch \
29 file://0016-yes-within-the-path-sets-wrong-config-variables.patch \
30 file://0017-timezone-re-written-tzselect-as-posix-sh.patch \
31 file://0018-eglibc-Cross-building-and-testing-instructions.patch \
32 file://0019-eglibc-Bring-Eglibc-option-group-infrastructure-to-g.patch \
33 file://0020-eglibc-Help-bootstrap-cross-toolchain.patch \
34 file://0021-eglibc-cherry-picked-from-http-www.eglibc.org-archiv.patch \
35 file://0022-eglibc-Clear-cache-lines-on-ppc8xx.patch \
36 file://0023-eglibc-Resolve-__fpscr_values-on-SH4.patch \
37 file://0024-eglibc-Forward-port-eglibc-options-groups-support.patch \
38 file://0025-eglibc-Install-PIC-archives.patch \
39 file://0026-eglibc-dl_debug_mask-is-controlled-by-__OPTION_EGLIB.patch \
40 file://0027-eglibc-use-option-groups-Conditionally-exclude-c-tes.patch \
41"
42
43SRC_URI += "\
44 file://etc/ld.so.conf \
45 file://generate-supported.mk \
46"
47
48SRC_URI_append_class-nativesdk = "\
49 file://0001-nativesdk-glibc-Look-for-host-system-ld.so.cache-as-.patch \
50 file://0002-nativesdk-glibc-Fix-buffer-overrun-with-a-relocated-.patch \
51 file://0003-nativesdk-glibc-Raise-the-size-of-arrays-containing-.patch \
52"
53
54S = "${WORKDIR}/git"
55B = "${WORKDIR}/build-${TARGET_SYS}"
56
57PACKAGES_DYNAMIC = ""
58
59# the -isystem in bitbake.conf screws up glibc do_stage
60BUILD_CPPFLAGS = "-I${STAGING_INCDIR_NATIVE}"
61TARGET_CPPFLAGS = "-I${STAGING_DIR_TARGET}${includedir}"
62
63GLIBC_BROKEN_LOCALES = " _ER _ET so_ET yn_ER sid_ET tr_TR mn_MN gez_ET gez_ER bn_BD te_IN es_CR.ISO-8859-1"
64
65#
66# We will skip parsing glibc when target system C library selection is not glibc
67# this helps in easing out parsing for non-glibc system libraries
68#
69COMPATIBLE_HOST_libc-musl_class-target = "null"
70COMPATIBLE_HOST_libc-uclibc_class-target = "null"
71
72EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
73 --without-cvs --disable-profile \
74 --disable-debug --without-gd \
75 --enable-clocale=gnu \
76 --enable-add-ons \
77 --with-headers=${STAGING_INCDIR} \
78 --without-selinux \
79 --enable-obsolete-rpc \
80 --with-kconfig=${STAGING_BINDIR_NATIVE} \
81 ${GLIBC_EXTRA_OECONF}"
82
83EXTRA_OECONF += "${@get_libc_fpu_setting(bb, d)}"
84EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'libc-inet-anl', '--enable-nscd', '--disable-nscd', d)}"
85
86
87do_patch_append() {
88 bb.build.exec_func('do_fix_readlib_c', d)
89}
90
91do_fix_readlib_c () {
92 sed -i -e 's#OECORE_KNOWN_INTERPRETER_NAMES#${EGLIBC_KNOWN_INTERPRETER_NAMES}#' ${S}/elf/readlib.c
93}
94
95do_configure () {
96# override this function to avoid the autoconf/automake/aclocal/autoheader
97# calls for now
98# don't pass CPPFLAGS into configure, since it upsets the kernel-headers
99# version check and doesn't really help with anything
100 if [ -z "`which rpcgen`" ]; then
101 echo "rpcgen not found. Install glibc-devel."
102 exit 1
103 fi
104 (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
105 find ${S} -name "configure" | xargs touch
106 CPPFLAGS="" oe_runconf
107}
108
109rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
110 yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
111 rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
112
113do_compile () {
114 # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
115 unset LDFLAGS
116 base_do_compile
117 (
118 cd ${S}/sunrpc/rpcsvc
119 for r in ${rpcsvc}; do
120 h=`echo $r|sed -e's,\.x$,.h,'`
121 rm -f $h
122 rpcgen -h $r -o $h || bbwarn "${PN}: unable to generate header for $r"
123 done
124 )
125 echo "Adjust ldd script"
126 if [ -n "${RTLDLIST}" ]
127 then
128 prevrtld=`cat ${B}/elf/ldd | grep "^RTLDLIST=" | sed 's#^RTLDLIST="\?\([^"]*\)"\?$#\1#'`
129 if [ "${prevrtld}" != "${RTLDLIST}" ]
130 then
131 sed -i ${B}/elf/ldd -e "s#^RTLDLIST=.*\$#RTLDLIST=\"${prevrtld} ${RTLDLIST}\"#"
132 fi
133 fi
134
135}
136
137require glibc-package.inc
138
139BBCLASSEXTEND = "nativesdk"