summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glibc/cross-localedef-native_2.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glibc/cross-localedef-native_2.20.bb')
-rw-r--r--meta/recipes-core/glibc/cross-localedef-native_2.20.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-core/glibc/cross-localedef-native_2.20.bb b/meta/recipes-core/glibc/cross-localedef-native_2.20.bb
new file mode 100644
index 0000000000..ccf56a9415
--- /dev/null
+++ b/meta/recipes-core/glibc/cross-localedef-native_2.20.bb
@@ -0,0 +1,52 @@
1SUMMARY = "Cross locale generation tool for glibc"
2HOMEPAGE = "http://www.gnu.org/software/libc/libc.html"
3SECTION = "libs"
4LICENSE = "LGPL-2.1"
5
6LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
9 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
10
11
12inherit native
13inherit autotools
14
15FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:${FILE_DIRNAME}/glibc:"
16
17PV = "2.20"
18
19SRC_URI = "git://sourceware.org/git/glibc.git;branch=release/${PV}/master;name=glibc \
20 git://github.com/kraj/localedef;branch=master;name=localedef;destsuffix=git/localedef \
21 file://fix_for_centos_5.8.patch \
22 ${EGLIBCPATCHES} \
23 "
24EGLIBCPATCHES = "\
25 file://timezone-re-written-tzselect-as-posix-sh.patch \
26 file://eglibc.patch \
27 file://option-groups.patch \
28 file://GLRO_dl_debug_mask.patch \
29 file://eglibc-header-bootstrap.patch \
30 file://eglibc-resolv-dynamic.patch \
31 file://eglibc-ppc8xx-cache-line-workaround.patch \
32 file://eglibc-sh4-fpscr_values.patch \
33 file://eglibc-use-option-groups.patch \
34 "
35
36SRCREV_glibc = "b8079dd0d360648e4e8de48656c5c38972621072"
37SRCREV_localedef = "c833367348d39dad7ba018990bfdaffaec8e9ed3"
38
39S = "${WORKDIR}/git"
40
41EXTRA_OECONF = "--with-glibc=${S}"
42CFLAGS += "-DNOT_IN_libc=1"
43
44do_configure () {
45 ${S}/localedef/configure ${EXTRA_OECONF}
46}
47
48
49do_install() {
50 install -d ${D}${bindir}
51 install -m 0755 ${B}/localedef ${D}${bindir}/cross-localedef
52}