summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-networking/glib-networking_2.78.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glib-networking/glib-networking_2.78.1.bb')
-rw-r--r--meta/recipes-core/glib-networking/glib-networking_2.78.1.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-networking/glib-networking_2.78.1.bb b/meta/recipes-core/glib-networking/glib-networking_2.78.1.bb
new file mode 100644
index 0000000000..5060d9fd7a
--- /dev/null
+++ b/meta/recipes-core/glib-networking/glib-networking_2.78.1.bb
@@ -0,0 +1,45 @@
1SUMMARY = "GLib networking extensions"
2DESCRIPTION = "glib-networking contains the implementations of certain GLib networking features that cannot be implemented directly in GLib itself because of their dependencies."
3HOMEPAGE = "https://gitlab.gnome.org/GNOME/glib-networking/"
4BUGTRACKER = "http://bugzilla.gnome.org"
5
6LICENSE = "LGPL-2.1-or-later"
7LICENSE:append = "${@bb.utils.contains('PACKAGECONFIG', 'openssl', ' & Glib-Networking-OpenSSL-Exception', '', d)}"
8NO_GENERIC_LICENSE[Glib-Networking-OpenSSL-Exception] = "LICENSE_EXCEPTION"
9
10LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
11 file://LICENSE_EXCEPTION;md5=0f5be697951b5e71aff00f4a4ce66be8 \
12 file://tls/base/gtlsconnection-base.c;beginline=7;endline=22;md5=ab641ac307f3337811008ea9afe7059f"
13
14SECTION = "libs"
15DEPENDS = "glib-2.0-native glib-2.0"
16
17SRC_URI[archive.sha256sum] = "e48f2ddbb049832cbb09230529c5e45daca9f0df0eda325f832f7379859bf09f"
18
19# Upstream note that for the openssl backend, half the tests where this backend don't return
20# the expected error code or don't work as expected so default to gnutls
21PACKAGECONFIG ??= "gnutls environment ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
22
23PACKAGECONFIG[gnutls] = "-Dgnutls=enabled,-Dgnutls=disabled,gnutls"
24PACKAGECONFIG[openssl] = "-Dopenssl=enabled,-Dopenssl=disabled,openssl"
25PACKAGECONFIG[environment] = "-Denvironment_proxy=enabled,-Denvironment_proxy=disabled"
26PACKAGECONFIG[libproxy] = "-Dlibproxy=enabled,-Dlibproxy=disabled,libproxy"
27PACKAGECONFIG[tests] = "-Dinstalled_tests=true,-Dinstalled_tests=false"
28PACKAGECONFIG[gnomeproxy] = "-Dgnome_proxy=enabled,-Dgnome_proxy=disabled,gsettings-desktop-schemas"
29
30inherit gnomebase gettext upstream-version-is-even gio-module-cache ptest-gnome
31
32SRC_URI += "file://run-ptest"
33SRC_URI += "file://eagain.patch"
34
35FILES:${PN} += "\
36 ${libdir}/gio/modules/libgio*.so \
37 ${datadir}/dbus-1/services/ \
38 ${systemd_user_unitdir} \
39 "
40FILES:${PN}-dev += "${libdir}/gio/modules/libgio*.la"
41FILES:${PN}-staticdev += "${libdir}/gio/modules/libgio*.a"
42
43RDEPENDS:${PN}-ptest += "bash"
44
45BBCLASSEXTEND = "native nativesdk"