summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-networking/glib-networking_2.76.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glib-networking/glib-networking_2.76.1.bb')
-rw-r--r--meta/recipes-core/glib-networking/glib-networking_2.76.1.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-networking/glib-networking_2.76.1.bb b/meta/recipes-core/glib-networking/glib-networking_2.76.1.bb
new file mode 100644
index 0000000000..8e7290cdbb
--- /dev/null
+++ b/meta/recipes-core/glib-networking/glib-networking_2.76.1.bb
@@ -0,0 +1,44 @@
1SUMMARY = "GLib networking extensions"
2DESCRIPTION = "glib-networking contains the implementations of certain GLib networking features that cannot be implemented directly in GLib itself because of their dependencies."
3HOMEPAGE = "https://gitlab.gnome.org/GNOME/glib-networking/"
4BUGTRACKER = "http://bugzilla.gnome.org"
5
6LICENSE = "LGPL-2.1-or-later"
7LICENSE:append = "${@bb.utils.contains('PACKAGECONFIG', 'openssl', ' & Glib-Networking-OpenSSL-Exception', '', d)}"
8NO_GENERIC_LICENSE[Glib-Networking-OpenSSL-Exception] = "LICENSE_EXCEPTION"
9
10LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
11 file://LICENSE_EXCEPTION;md5=0f5be697951b5e71aff00f4a4ce66be8 \
12 file://tls/base/gtlsconnection-base.c;beginline=7;endline=22;md5=ab641ac307f3337811008ea9afe7059f"
13
14SECTION = "libs"
15DEPENDS = "glib-2.0-native glib-2.0"
16
17SRC_URI[archive.sha256sum] = "5c698a9994dde51efdfb1026a56698a221d6250e89dc50ebcddda7b81480a42b"
18
19PACKAGECONFIG ??= "openssl environment ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
20
21PACKAGECONFIG[gnutls] = "-Dgnutls=enabled,-Dgnutls=disabled,gnutls"
22PACKAGECONFIG[openssl] = "-Dopenssl=enabled,-Dopenssl=disabled,openssl"
23PACKAGECONFIG[environment] = "-Denvironment_proxy=enabled,-Denvironment_proxy=disabled"
24PACKAGECONFIG[libproxy] = "-Dlibproxy=enabled,-Dlibproxy=disabled,libproxy"
25PACKAGECONFIG[tests] = "-Dinstalled_tests=true,-Dinstalled_tests=false"
26PACKAGECONFIG[gnomeproxy] = "-Dgnome_proxy=enabled,-Dgnome_proxy=disabled,gsettings-desktop-schemas"
27
28GNOMEBASEBUILDCLASS = "meson"
29inherit gnomebase gettext upstream-version-is-even gio-module-cache ptest-gnome
30
31SRC_URI += "file://run-ptest"
32SRC_URI += "file://eagain.patch"
33
34FILES:${PN} += "\
35 ${libdir}/gio/modules/libgio*.so \
36 ${datadir}/dbus-1/services/ \
37 ${systemd_user_unitdir} \
38 "
39FILES:${PN}-dev += "${libdir}/gio/modules/libgio*.la"
40FILES:${PN}-staticdev += "${libdir}/gio/modules/libgio*.a"
41
42RDEPENDS:${PN}-ptest += "bash"
43
44BBCLASSEXTEND = "native nativesdk"