summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/glib-2.0/glib-2.0_2.78.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/glib-2.0/glib-2.0_2.78.1.bb')
-rw-r--r--meta/recipes-core/glib-2.0/glib-2.0_2.78.1.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.78.1.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.78.1.bb
new file mode 100644
index 0000000000..a490262112
--- /dev/null
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.78.1.bb
@@ -0,0 +1,53 @@
1require glib.inc
2
3PE = "1"
4
5SHRT_VER = "${@oe.utils.trim_version("${PV}", 2)}"
6
7SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.xz \
8 file://run-ptest \
9 file://0001-Fix-DATADIRNAME-on-uclibc-Linux.patch \
10 file://0001-Remove-the-warning-about-deprecated-paths-in-schemas.patch \
11 file://0001-Install-gio-querymodules-as-libexec_PROGRAM.patch \
12 file://0010-Do-not-hardcode-python-path-into-various-tools.patch \
13 file://0001-Set-host_machine-correctly-when-building-with-mingw3.patch \
14 file://0001-Do-not-write-bindir-into-pkg-config-files.patch \
15 file://0001-meson-Run-atomics-test-on-clang-as-well.patch \
16 file://0001-gio-tests-resources.c-comment-out-a-build-host-only-.patch \
17 "
18SRC_URI:append:class-native = " file://relocate-modules.patch \
19 file://0001-meson.build-do-not-enable-pidfd-features-on-native-g.patch \
20 "
21
22SRC_URI[sha256sum] = "915bc3d0f8507d650ead3832e2f8fb670fce59aac4d7754a7dab6f1e6fed78b2"
23
24# Find any meson cross files in FILESPATH that are relevant for the current
25# build (using siteinfo) and add them to EXTRA_OEMESON.
26inherit siteinfo
27def find_meson_cross_files(d):
28 if bb.data.inherits_class('native', d):
29 return ""
30
31 thisdir = os.path.normpath(d.getVar("THISDIR"))
32 import collections
33 sitedata = siteinfo_data(d)
34 # filename -> found
35 files = collections.OrderedDict()
36 for path in d.getVar("FILESPATH").split(":"):
37 for element in sitedata:
38 filename = os.path.normpath(os.path.join(path, "meson.cross.d", element))
39 sanitized_path = filename.replace(thisdir, "${THISDIR}")
40 if sanitized_path == filename:
41 if os.path.exists(filename):
42 bb.error("Cannot add '%s' to --cross-file, because it's not relative to THISDIR '%s' and sstate signature would contain this full path" % (filename, thisdir))
43 continue
44 files[filename.replace(thisdir, "${THISDIR}")] = os.path.exists(filename)
45
46 items = ["--cross-file=" + k for k,v in files.items() if v]
47 d.appendVar("EXTRA_OEMESON", " " + " ".join(items))
48 items = ["%s:%s" % (k, "True" if v else "False") for k,v in files.items()]
49 d.appendVarFlag("do_configure", "file-checksums", " " + " ".join(items))
50
51python () {
52 find_meson_cross_files(d)
53}