diff options
Diffstat (limited to 'meta/recipes-core/glib-2.0/glib-2.0_2.74.6.bb')
-rw-r--r-- | meta/recipes-core/glib-2.0/glib-2.0_2.74.6.bb | 55 |
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.74.6.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.74.6.bb new file mode 100644 index 0000000000..5b79ae481c --- /dev/null +++ b/meta/recipes-core/glib-2.0/glib-2.0_2.74.6.bb | |||
@@ -0,0 +1,55 @@ | |||
1 | require glib.inc | ||
2 | |||
3 | PE = "1" | ||
4 | |||
5 | SHRT_VER = "${@oe.utils.trim_version("${PV}", 2)}" | ||
6 | |||
7 | SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.xz \ | ||
8 | file://run-ptest \ | ||
9 | file://0001-Fix-DATADIRNAME-on-uclibc-Linux.patch \ | ||
10 | file://0001-Remove-the-warning-about-deprecated-paths-in-schemas.patch \ | ||
11 | file://0001-Install-gio-querymodules-as-libexec_PROGRAM.patch \ | ||
12 | file://0010-Do-not-hardcode-python-path-into-various-tools.patch \ | ||
13 | file://0001-Set-host_machine-correctly-when-building-with-mingw3.patch \ | ||
14 | file://0001-Do-not-write-bindir-into-pkg-config-files.patch \ | ||
15 | file://0001-meson-Run-atomics-test-on-clang-as-well.patch \ | ||
16 | file://0001-gio-tests-resources.c-comment-out-a-build-host-only-.patch \ | ||
17 | file://0001-gio-tests-g-file-info-don-t-assume-million-in-one-ev.patch \ | ||
18 | file://0001-gio-tests-meson.build-do-not-use-can_run_host_binari.patch \ | ||
19 | file://cpp-null.patch \ | ||
20 | file://cpp-null2.patch \ | ||
21 | " | ||
22 | SRC_URI:append:class-native = " file://relocate-modules.patch" | ||
23 | |||
24 | SRC_URI[sha256sum] = "069cf7e51cd261eb163aaf06c8d1754c6835f31252180aff5814e5afc7757fbc" | ||
25 | |||
26 | # Find any meson cross files in FILESPATH that are relevant for the current | ||
27 | # build (using siteinfo) and add them to EXTRA_OEMESON. | ||
28 | inherit siteinfo | ||
29 | def find_meson_cross_files(d): | ||
30 | if bb.data.inherits_class('native', d): | ||
31 | return "" | ||
32 | |||
33 | thisdir = os.path.normpath(d.getVar("THISDIR")) | ||
34 | import collections | ||
35 | sitedata = siteinfo_data(d) | ||
36 | # filename -> found | ||
37 | files = collections.OrderedDict() | ||
38 | for path in d.getVar("FILESPATH").split(":"): | ||
39 | for element in sitedata: | ||
40 | filename = os.path.normpath(os.path.join(path, "meson.cross.d", element)) | ||
41 | sanitized_path = filename.replace(thisdir, "${THISDIR}") | ||
42 | if sanitized_path == filename: | ||
43 | if os.path.exists(filename): | ||
44 | bb.error("Cannot add '%s' to --cross-file, because it's not relative to THISDIR '%s' and sstate signature would contain this full path" % (filename, thisdir)) | ||
45 | continue | ||
46 | files[filename.replace(thisdir, "${THISDIR}")] = os.path.exists(filename) | ||
47 | |||
48 | items = ["--cross-file=" + k for k,v in files.items() if v] | ||
49 | d.appendVar("EXTRA_OEMESON", " " + " ".join(items)) | ||
50 | items = ["%s:%s" % (k, "True" if v else "False") for k,v in files.items()] | ||
51 | d.appendVarFlag("do_configure", "file-checksums", " " + " ".join(items)) | ||
52 | |||
53 | python () { | ||
54 | find_meson_cross_files(d) | ||
55 | } | ||