summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext_0.14.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/gettext/gettext_0.14.1.bb')
-rw-r--r--meta/recipes-core/gettext/gettext_0.14.1.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext_0.14.1.bb b/meta/recipes-core/gettext/gettext_0.14.1.bb
new file mode 100644
index 0000000000..a2de018281
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext_0.14.1.bb
@@ -0,0 +1,52 @@
1DESCRIPTION = "The GNU internationalization library."
2HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
3SECTION = "libs"
4LICENSE = "GPLv2"
5PR = "r11"
6DEPENDS = "virtual/libiconv"
7DEPENDS_virtclass-native = ""
8PROVIDES = "virtual/libintl"
9PROVIDES_virtclass-native = ""
10
11SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
12 file://gettext-vpath.patch \
13 file://fixchicken.patch \
14 file://linklib_from_0.17.patch \
15 file://getline.m4.patch \
16 file://disable_java.patch"
17
18# file://gettext-autoconf-lib-link-no-L.patch \
19
20SRC_URI_append_linux-uclibc = " file://gettext-error_print_progname.patch"
21SRC_URI_append_linux-uclibceabi = " file://gettext-error_print_progname.patch"
22
23PARALLEL_MAKE = ""
24
25inherit autotools
26
27EXTRA_OECONF += "--without-lisp --disable-csharp"
28acpaths = '-I ${S}/autoconf-lib-link/m4/ \
29 -I ${S}/gettext-runtime/m4 \
30 -I ${S}/gettext-tools/m4'
31
32do_configure_prepend() {
33 rm -f ${S}/config/m4/libtool.m4
34}
35
36# these lack the .x behind the .so, but shouldn't be in the -dev package
37# Otherwise you get the following results:
38# 7.4M glibc/images/ep93xx/Angstrom-console-image-glibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
39# 25M uclibc/images/ep93xx/Angstrom-console-image-uclibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
40# because gettext depends on gettext-dev, which pulls in more -dev packages:
41# 15228 KiB /ep93xx/libstdc++-dev_4.2.2-r2_ep93xx.ipk
42# 1300 KiB /ep93xx/uclibc-dev_0.9.29-r8_ep93xx.ipk
43# 140 KiB /armv4t/gettext-dev_0.14.1-r6_armv4t.ipk
44# 4 KiB /ep93xx/libgcc-s-dev_4.2.2-r2_ep93xx.ipk
45
46PACKAGES =+ "libgettextlib libgettextsrc"
47FILES_libgettextlib = "${libdir}/libgettextlib-*.so*"
48FILES_libgettextsrc = "${libdir}/libgettextsrc-*.so*"
49
50
51SRC_URI[md5sum] = "78f4b862510beb2e5d43223dd610e77d"
52SRC_URI[sha256sum] = "41f20c469c7759acb34cfa7e0b3cac9096d59a58ad800e471f07424a8e7adbb7"