summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/gettext/gettext-minimal-native_0.22.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/gettext/gettext-minimal-native_0.22.5.bb')
-rw-r--r--meta/recipes-core/gettext/gettext-minimal-native_0.22.5.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-core/gettext/gettext-minimal-native_0.22.5.bb b/meta/recipes-core/gettext/gettext-minimal-native_0.22.5.bb
new file mode 100644
index 0000000000..db1bbb7e68
--- /dev/null
+++ b/meta/recipes-core/gettext/gettext-minimal-native_0.22.5.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Minimal gettext for supporting native autoconf/automake"
2DESCRIPTION = "Contains the m4 macros sufficient to support building \
3autoconf/automake. This provides a significant build time speedup by \
4the removal of gettext-native from most dependency chains (now only \
5needed for gettext for the target)."
6
7require gettext-sources.inc
8SRC_URI += " \
9 file://COPYING \
10"
11
12INHIBIT_DEFAULT_DEPS = "1"
13INHIBIT_AUTOTOOLS_DEPS = "1"
14
15LICENSE = "FSF-Unlimited"
16LIC_FILES_CHKSUM = "file://../COPYING;md5=4bd090a20bfcd1a18f1f79837b5e3e91"
17
18inherit native
19
20S = "${WORKDIR}/gettext-${PV}"
21
22python get_aclocal_files() {
23 fpath = oe.path.join(d.getVar("S"), "/gettext-tools/m4/Makefile.am")
24 with open(fpath) as f:
25 content = f.read()
26 for l in content.replace("\\\n","").split("\n"):
27 if l.startswith("aclocal_DATA"):
28 aclocal_files = l.split("=")[1]
29 with open(oe.path.join(d.getVar("WORKDIR"),"aclocal-files"),'w') as outf:
30 outf.write(aclocal_files)
31 break
32 else:
33 bb.error("Could not obtain list of installed aclocal files from {}".format(fpath))
34}
35do_install[prefuncs] += "get_aclocal_files"
36
37do_install () {
38 install -d ${D}${datadir}/aclocal/
39 for i in `cat ${WORKDIR}/aclocal-files`; do
40 cp ${S}/gettext-tools/m4/$i ${D}${datadir}/aclocal/
41 done
42 install -d ${D}${datadir}/gettext/po/
43 cp ${S}/build-aux/config.rpath ${D}${datadir}/gettext/
44 cp ${S}/gettext-runtime/po/Makefile.in.in ${D}${datadir}/gettext/po/
45 cp ${S}/gettext-runtime/po/remove-potcdate.sin ${D}${datadir}/gettext/po/
46}