diff options
Diffstat (limited to 'meta/recipes-core/gettext/gettext-minimal-native_0.21.1.bb')
-rw-r--r-- | meta/recipes-core/gettext/gettext-minimal-native_0.21.1.bb | 36 |
1 files changed, 26 insertions, 10 deletions
diff --git a/meta/recipes-core/gettext/gettext-minimal-native_0.21.1.bb b/meta/recipes-core/gettext/gettext-minimal-native_0.21.1.bb index 7a4dcbec57..db1bbb7e68 100644 --- a/meta/recipes-core/gettext/gettext-minimal-native_0.21.1.bb +++ b/meta/recipes-core/gettext/gettext-minimal-native_0.21.1.bb | |||
@@ -3,10 +3,9 @@ DESCRIPTION = "Contains the m4 macros sufficient to support building \ | |||
3 | autoconf/automake. This provides a significant build time speedup by \ | 3 | autoconf/automake. This provides a significant build time speedup by \ |
4 | the removal of gettext-native from most dependency chains (now only \ | 4 | the removal of gettext-native from most dependency chains (now only \ |
5 | needed for gettext for the target)." | 5 | needed for gettext for the target)." |
6 | SRC_URI = "file://aclocal/ \ | 6 | |
7 | file://config.rpath \ | 7 | require gettext-sources.inc |
8 | file://Makefile.in.in \ | 8 | SRC_URI += " \ |
9 | file://remove-potcdate.sin \ | ||
10 | file://COPYING \ | 9 | file://COPYING \ |
11 | " | 10 | " |
12 | 11 | ||
@@ -14,17 +13,34 @@ INHIBIT_DEFAULT_DEPS = "1" | |||
14 | INHIBIT_AUTOTOOLS_DEPS = "1" | 13 | INHIBIT_AUTOTOOLS_DEPS = "1" |
15 | 14 | ||
16 | LICENSE = "FSF-Unlimited" | 15 | LICENSE = "FSF-Unlimited" |
17 | LIC_FILES_CHKSUM = "file://COPYING;md5=4bd090a20bfcd1a18f1f79837b5e3e91" | 16 | LIC_FILES_CHKSUM = "file://../COPYING;md5=4bd090a20bfcd1a18f1f79837b5e3e91" |
18 | 17 | ||
19 | inherit native | 18 | inherit native |
20 | 19 | ||
21 | S = "${WORKDIR}" | 20 | S = "${WORKDIR}/gettext-${PV}" |
21 | |||
22 | python get_aclocal_files() { | ||
23 | fpath = oe.path.join(d.getVar("S"), "/gettext-tools/m4/Makefile.am") | ||
24 | with open(fpath) as f: | ||
25 | content = f.read() | ||
26 | for l in content.replace("\\\n","").split("\n"): | ||
27 | if l.startswith("aclocal_DATA"): | ||
28 | aclocal_files = l.split("=")[1] | ||
29 | with open(oe.path.join(d.getVar("WORKDIR"),"aclocal-files"),'w') as outf: | ||
30 | outf.write(aclocal_files) | ||
31 | break | ||
32 | else: | ||
33 | bb.error("Could not obtain list of installed aclocal files from {}".format(fpath)) | ||
34 | } | ||
35 | do_install[prefuncs] += "get_aclocal_files" | ||
22 | 36 | ||
23 | do_install () { | 37 | do_install () { |
24 | install -d ${D}${datadir}/aclocal/ | 38 | install -d ${D}${datadir}/aclocal/ |
25 | cp ${WORKDIR}/aclocal/*.m4 ${D}${datadir}/aclocal/ | 39 | for i in `cat ${WORKDIR}/aclocal-files`; do |
40 | cp ${S}/gettext-tools/m4/$i ${D}${datadir}/aclocal/ | ||
41 | done | ||
26 | install -d ${D}${datadir}/gettext/po/ | 42 | install -d ${D}${datadir}/gettext/po/ |
27 | cp ${WORKDIR}/config.rpath ${D}${datadir}/gettext/ | 43 | cp ${S}/build-aux/config.rpath ${D}${datadir}/gettext/ |
28 | cp ${WORKDIR}/Makefile.in.in ${D}${datadir}/gettext/po/ | 44 | cp ${S}/gettext-runtime/po/Makefile.in.in ${D}${datadir}/gettext/po/ |
29 | cp ${WORKDIR}/remove-potcdate.sin ${D}${datadir}/gettext/po/ | 45 | cp ${S}/gettext-runtime/po/remove-potcdate.sin ${D}${datadir}/gettext/po/ |
30 | } | 46 | } |