summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/expat/expat_2.5.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/expat/expat_2.5.0.bb')
-rw-r--r--meta/recipes-core/expat/expat_2.5.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-core/expat/expat_2.5.0.bb b/meta/recipes-core/expat/expat_2.5.0.bb
new file mode 100644
index 0000000000..aa8d439d5f
--- /dev/null
+++ b/meta/recipes-core/expat/expat_2.5.0.bb
@@ -0,0 +1,32 @@
1SUMMARY = "A stream-oriented XML parser library"
2DESCRIPTION = "Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags)"
3HOMEPAGE = "https://github.com/libexpat/libexpat"
4SECTION = "libs"
5LICENSE = "MIT"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=7b3b078238d0901d3b339289117cb7fb"
8
9VERSION_TAG = "${@d.getVar('PV').replace('.', '_')}"
10
11SRC_URI = "${GITHUB_BASE_URI}/download/R_${VERSION_TAG}/expat-${PV}.tar.bz2 \
12 file://run-ptest \
13 "
14
15GITHUB_BASE_URI = "https://github.com/libexpat/libexpat/releases/"
16UPSTREAM_CHECK_REGEX = "releases/tag/R_(?P<pver>.+)"
17
18SRC_URI[sha256sum] = "6f0e6e01f7b30025fa05c85fdad1e5d0ec7fd35d9f61b22f34998de11969ff67"
19
20EXTRA_OECMAKE:class-native += "-DEXPAT_BUILD_DOCS=OFF"
21
22RDEPENDS:${PN}-ptest += "bash"
23
24inherit cmake lib_package ptest github-releases
25
26do_install_ptest:class-target() {
27 install -m 755 ${B}/tests/* ${D}${PTEST_PATH}
28}
29
30BBCLASSEXTEND += "native nativesdk"
31
32CVE_PRODUCT = "expat libexpat"