summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/expat/expat_2.4.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/expat/expat_2.4.3.bb')
-rw-r--r--meta/recipes-core/expat/expat_2.4.3.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-core/expat/expat_2.4.3.bb b/meta/recipes-core/expat/expat_2.4.3.bb
new file mode 100644
index 0000000000..279774af43
--- /dev/null
+++ b/meta/recipes-core/expat/expat_2.4.3.bb
@@ -0,0 +1,32 @@
1SUMMARY = "A stream-oriented XML parser library"
2DESCRIPTION = "Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags)"
3HOMEPAGE = "https://github.com/libexpat/libexpat"
4SECTION = "libs"
5LICENSE = "MIT"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=9e2ce3b3c4c0f2670883a23bbd7c37a9"
8
9VERSION_TAG = "${@d.getVar('PV').replace('.', '_')}"
10
11SRC_URI = "https://github.com/libexpat/libexpat/releases/download/R_${VERSION_TAG}/expat-${PV}.tar.bz2 \
12 file://libtool-tag.patch \
13 file://run-ptest \
14 "
15
16UPSTREAM_CHECK_URI = "https://github.com/libexpat/libexpat/releases/"
17
18SRC_URI[sha256sum] = "6f262e216a494fbf42d8c22bc841b3e117c21f2467a19dc4c27c991b5622f986"
19
20EXTRA_OECMAKE:class-native += "-DEXPAT_BUILD_DOCS=OFF"
21
22RDEPENDS:${PN}-ptest += "bash"
23
24inherit cmake lib_package ptest
25
26do_install_ptest:class-target() {
27 install -m 755 ${B}/tests/* ${D}${PTEST_PATH}
28}
29
30BBCLASSEXTEND += "native nativesdk"
31
32CVE_PRODUCT = "expat libexpat"