summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/expat/expat_2.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/expat/expat_2.4.1.bb')
-rw-r--r--meta/recipes-core/expat/expat_2.4.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-core/expat/expat_2.4.1.bb b/meta/recipes-core/expat/expat_2.4.1.bb
new file mode 100644
index 0000000000..a57fc1b23b
--- /dev/null
+++ b/meta/recipes-core/expat/expat_2.4.1.bb
@@ -0,0 +1,26 @@
1SUMMARY = "A stream-oriented XML parser library"
2DESCRIPTION = "Expat is an XML parser library written in C. It is a stream-oriented parser in which an application registers handlers for things the parser might find in the XML document (like start tags)"
3HOMEPAGE = "http://expat.sourceforge.net/"
4SECTION = "libs"
5LICENSE = "MIT"
6
7LIC_FILES_CHKSUM = "file://COPYING;md5=9e2ce3b3c4c0f2670883a23bbd7c37a9"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/expat/expat-${PV}.tar.bz2 \
10 file://libtool-tag.patch \
11 file://run-ptest \
12 "
13
14SRC_URI[sha256sum] = "2f9b6a580b94577b150a7d5617ad4643a4301a6616ff459307df3e225bcfbf40"
15
16EXTRA_OECMAKE_class-native += "-DEXPAT_BUILD_DOCS=OFF"
17
18RDEPENDS_${PN}-ptest += "bash"
19
20inherit cmake lib_package ptest
21
22do_install_ptest_class-target() {
23 install -m 755 ${B}/tests/* ${D}${PTEST_PATH}
24}
25
26BBCLASSEXTEND += "native nativesdk"