summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/eglibc/cross-localedef-native_2.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/eglibc/cross-localedef-native_2.13.bb')
-rw-r--r--meta/recipes-core/eglibc/cross-localedef-native_2.13.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-core/eglibc/cross-localedef-native_2.13.bb b/meta/recipes-core/eglibc/cross-localedef-native_2.13.bb
new file mode 100644
index 0000000000..68ef86439d
--- /dev/null
+++ b/meta/recipes-core/eglibc/cross-localedef-native_2.13.bb
@@ -0,0 +1,44 @@
1DESCRIPTION = "Cross locale generation tool for eglibc"
2HOMEPAGE = "http://www.eglibc.org/home"
3SECTION = "libs"
4PRIORITY = "required"
5LICENSE = "LGPL"
6
7LIC_DIR = "${WORKDIR}/${EGLIBC_BRANCH}/libc"
8LIC_FILES_CHKSUM = "file://${LIC_DIR}/LICENSES;md5=07a394b26e0902b9ffdec03765209770 \
9 file://${LIC_DIR}/COPYING;md5=393a5ca445f6965873eca0259a17f833 \
10 file://${LIC_DIR}/posix/rxspencer/COPYRIGHT;md5=dc5485bb394a13b2332ec1c785f5d83a \
11 file://${LIC_DIR}/COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff "
12
13
14inherit native
15inherit autotools
16
17PR = "r1"
18SRCREV="11982"
19EGLIBC_BRANCH="eglibc-2_12"
20SRC_URI = "svn://www.eglibc.org/svn/branches/;module=${EGLIBC_BRANCH};proto=http "
21S = "${WORKDIR}/${EGLIBC_BRANCH}/localedef"
22
23do_unpack_append() {
24 bb.build.exec_func('do_move_ports', d)
25}
26
27do_move_ports() {
28 if test -d ${WORKDIR}/${EGLIBC_BRANCH}/ports ; then
29 rm -rf ${WORKDIR}/libc/ports
30 mv ${WORKDIR}/${EGLIBC_BRANCH}/ports ${WORKDIR}/libc/
31 fi
32}
33
34EXTRA_OECONF = "--with-glibc=${WORKDIR}/${EGLIBC_BRANCH}/libc"
35
36do_configure () {
37 ./configure ${EXTRA_OECONF}
38}
39
40
41do_install() {
42 install -d ${D}${bindir}
43 install -m 0755 ${S}/localedef ${D}${bindir}/cross-localedef
44}