summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus/dbus-test_1.12.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/dbus/dbus-test_1.12.8.bb')
-rw-r--r--meta/recipes-core/dbus/dbus-test_1.12.8.bb82
1 files changed, 82 insertions, 0 deletions
diff --git a/meta/recipes-core/dbus/dbus-test_1.12.8.bb b/meta/recipes-core/dbus/dbus-test_1.12.8.bb
new file mode 100644
index 0000000000..f33fbaf39a
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-test_1.12.8.bb
@@ -0,0 +1,82 @@
1SUMMARY = "D-Bus test package (for D-bus functionality testing only)"
2HOMEPAGE = "http://dbus.freedesktop.org"
3SECTION = "base"
4LICENSE = "AFL-2 | GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=10dded3b58148f3f1fd804b26354af3e \
6 file://dbus/dbus.h;beginline=6;endline=20;md5=7755c9d7abccd5dbd25a6a974538bb3c"
7
8DEPENDS = "dbus glib-2.0"
9
10RDEPENDS_${PN} += "make"
11RDEPENDS_${PN}-dev = ""
12
13SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
14 file://tmpdir.patch \
15 file://run-ptest \
16 file://python-config.patch \
17 file://clear-guid_from_server-if-send_negotiate_unix_f.patch \
18 "
19
20SRC_URI[md5sum] = "2764bf150e5aa8005b7bc0d6c388756a"
21SRC_URI[sha256sum] = "e2dc99e7338303393b6663a98320aba6a63421bcdaaf571c8022f815e5896eb3"
22
23S="${WORKDIR}/dbus-${PV}"
24FILESEXTRAPATHS =. "${FILE_DIRNAME}/dbus:"
25
26inherit autotools pkgconfig gettext ptest upstream-version-is-even
27
28EXTRA_OECONF_X = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '--with-x', '--without-x', d)}"
29EXTRA_OECONF_X_class-native = "--without-x"
30
31EXTRA_OECONF = "--enable-tests \
32 --enable-modular-tests \
33 --enable-installed-tests \
34 --enable-checks \
35 --enable-asserts \
36 --enable-verbose-mode \
37 --enable-largefile \
38 --disable-xml-docs \
39 --disable-doxygen-docs \
40 --disable-libaudit \
41 --with-dbus-test-dir=${PTEST_PATH} \
42 ${EXTRA_OECONF_X}"
43
44EXTRA_OECONF_append_class-target = " SYSTEMCTL=${base_bindir}/systemctl"
45
46PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd x11', d)}"
47PACKAGECONFIG_class-native = ""
48PACKAGECONFIG_class-nativesdk = ""
49
50PACKAGECONFIG[systemd] = "--enable-systemd --with-systemdsystemunitdir=${systemd_system_unitdir},--disable-systemd --without-systemdsystemunitdir,systemd"
51PACKAGECONFIG[x11] = "--with-x --enable-x11-autolaunch,--without-x --disable-x11-autolaunch, virtual/libx11 libsm"
52PACKAGECONFIG[user-session] = "--enable-user-session --with-systemduserunitdir=${systemd_user_unitdir},--disable-user-session"
53
54do_install() {
55 :
56}
57
58do_install_ptest() {
59 install -d ${D}${PTEST_PATH}/test
60 l="shell printf refs syslog marshal syntax corrupt dbus-daemon dbus-daemon-eavesdrop loopback relay \
61 variant uid-permissions syntax spawn sd-activation names monitor message fdpass "
62 for i in $l; do install ${B}/test/.libs/test-$i ${D}${PTEST_PATH}/test; done
63
64 l="bus bus-system bus-launch-helper"
65 for i in $l; do install ${B}/bus/.libs/test-$i ${D}${PTEST_PATH}/test; done
66
67 cp -r ${B}/test/data ${D}${PTEST_PATH}/test
68 install ${B}/dbus/.libs/test-dbus ${D}${PTEST_PATH}/test
69
70 install -d ${D}${PTEST_PATH}/test/.libs
71 cp -a ${B}/dbus/.libs/*.so* ${D}${PTEST_PATH}/test/.libs
72
73 # Remove build host references...
74 find "${D}${PTEST_PATH}/test/data" \( -name *.service -o -name *.conf -o -name "*.aaprofile" \) -type f -exec \
75 sed -i \
76 -e 's:${B}:${PTEST_PATH}:g' \
77 {} +
78}
79
80RDEPENDS_${PN}-ptest += "bash"
81
82PRIVATE_LIBS_${PN}-ptest = "libdbus-1.so.3"