summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus/dbus-test_1.10.20.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/dbus/dbus-test_1.10.20.bb')
-rw-r--r--meta/recipes-core/dbus/dbus-test_1.10.20.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-core/dbus/dbus-test_1.10.20.bb b/meta/recipes-core/dbus/dbus-test_1.10.20.bb
new file mode 100644
index 0000000000..eeadb7d35b
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-test_1.10.20.bb
@@ -0,0 +1,58 @@
1SUMMARY = "D-Bus test package (for D-bus functionality testing only)"
2HOMEPAGE = "http://dbus.freedesktop.org"
3SECTION = "base"
4LICENSE = "AFL-2 | GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=10dded3b58148f3f1fd804b26354af3e \
6 file://dbus/dbus.h;beginline=6;endline=20;md5=7755c9d7abccd5dbd25a6a974538bb3c"
7
8DEPENDS = "dbus glib-2.0"
9
10RDEPENDS_${PN} += "make"
11RDEPENDS_${PN}-dev = ""
12
13SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
14 file://tmpdir.patch \
15 file://run-ptest \
16 file://python-config.patch \
17 file://clear-guid_from_server-if-send_negotiate_unix_f.patch \
18 "
19
20SRC_URI[md5sum] = "94c991e763d4f9f13690416b2dcd9411"
21SRC_URI[sha256sum] = "e574b9780b5425fde4d973bb596e7ea0f09e00fe2edd662da9016e976c460b48"
22
23S="${WORKDIR}/dbus-${PV}"
24FILESEXTRAPATHS =. "${FILE_DIRNAME}/dbus:"
25
26inherit autotools pkgconfig gettext ptest upstream-version-is-even
27
28EXTRA_OECONF_X = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '--with-x', '--without-x', d)}"
29EXTRA_OECONF_X_class-native = "--without-x"
30
31EXTRA_OECONF = "--enable-tests \
32 --enable-modular-tests \
33 --enable-installed-tests \
34 --enable-checks \
35 --enable-asserts \
36 --enable-verbose-mode \
37 --disable-xml-docs \
38 --disable-doxygen-docs \
39 --disable-libaudit \
40 --disable-systemd \
41 --without-systemdsystemunitdir \
42 --with-dbus-test-dir=${PTEST_PATH} \
43 ${EXTRA_OECONF_X}"
44
45do_install() {
46 :
47}
48
49do_install_ptest() {
50 install -d ${D}${PTEST_PATH}/test
51 l="shell printf refs syslog marshal syntax corrupt dbus-daemon dbus-daemon-eavesdrop loopback relay"
52 for i in $l; do install ${B}/test/.libs/test-$i ${D}${PTEST_PATH}/test; done
53 l="bus bus-system bus-launch-helper"
54 for i in $l; do install ${B}/bus/.libs/test-$i ${D}${PTEST_PATH}/test; done
55 install ${B}/dbus/.libs/test-dbus ${D}${PTEST_PATH}/test
56 cp -r ${B}/test/data ${D}${PTEST_PATH}/test
57}
58RDEPENDS_${PN}-ptest += "bash"