summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core/dbus/dbus-glib_0.112.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-core/dbus/dbus-glib_0.112.bb')
-rw-r--r--meta/recipes-core/dbus/dbus-glib_0.112.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-core/dbus/dbus-glib_0.112.bb b/meta/recipes-core/dbus/dbus-glib_0.112.bb
new file mode 100644
index 0000000000..4acf435694
--- /dev/null
+++ b/meta/recipes-core/dbus/dbus-glib_0.112.bb
@@ -0,0 +1,39 @@
1SUMMARY = "High level language (GLib) binding for D-Bus"
2DESCRIPTION = "GLib bindings for the D-Bus message bus that integrate \
3the D-Bus library with the GLib thread abstraction and main loop."
4HOMEPAGE = "https://www.freedesktop.org/Software/dbus"
5LICENSE = "AFL-2.1 | GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=c31c73c1d8f5d06784b2ccd22e42d641 \
7 file://dbus/dbus-glib.h;beginline=7;endline=21;md5=c374833bd817988323f3a8fda0dc7f48"
8SECTION = "base"
9
10DEPENDS = "expat glib-2.0 virtual/libintl dbus-glib-native dbus"
11DEPENDS:class-native = "glib-2.0-native dbus-native"
12
13SRC_URI = "https://dbus.freedesktop.org/releases/dbus-glib/dbus-glib-${PV}.tar.gz \
14 file://no-examples.patch \
15 file://test-install-makefile.patch \
16"
17SRC_URI[md5sum] = "021e6c8a288df02c227e4aafbf7e7527"
18SRC_URI[sha256sum] = "7d550dccdfcd286e33895501829ed971eeb65c614e73aadb4a08aeef719b143a"
19
20inherit autotools pkgconfig gettext bash-completion gtk-doc
21
22#default disable regression tests, some unit test code in non testing code
23#PACKAGECONFIG:pn-${PN} = "tests" enable regression tests local.conf
24PACKAGECONFIG ??= ""
25PACKAGECONFIG[tests] = "--enable-tests,,,"
26
27EXTRA_OECONF:class-target = "--with-dbus-binding-tool=${STAGING_BINDIR_NATIVE}/dbus-binding-tool"
28
29PACKAGES += "${PN}-tests"
30
31FILES:${PN} = "${libdir}/lib*${SOLIBS}"
32FILES:${PN}-bash-completion += "${libexecdir}/dbus-bash-completion-helper"
33FILES:${PN}-dev += "${libdir}/dbus-1.0/include ${bindir}/dbus-glib-tool"
34FILES:${PN}-dev += "${bindir}/dbus-binding-tool"
35
36RDEPENDS:${PN}-tests += "dbus-x11"
37FILES:${PN}-tests = "${datadir}/${BPN}/tests"
38
39BBCLASSEXTEND = "native"