summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.9.bb')
-rw-r--r--meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.9.bb115
1 files changed, 0 insertions, 115 deletions
diff --git a/meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.9.bb b/meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.9.bb
deleted file mode 100644
index caa6018ce8..0000000000
--- a/meta/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.9.bb
+++ /dev/null
@@ -1,115 +0,0 @@
1SUMMARY = "Client for Wi-Fi Protected Access (WPA)"
2HOMEPAGE = "http://w1.fi/wpa_supplicant/"
3DESCRIPTION = "wpa_supplicant is a WPA Supplicant for Linux, BSD, Mac OS X, and Windows with support for WPA and WPA2 (IEEE 802.11i / RSN). Supplicant is the IEEE 802.1X/WPA component that is used in the client stations. It implements key negotiation with a WPA Authenticator and it controls the roaming and IEEE 802.11 authentication/association of the wlan driver."
4BUGTRACKER = "http://w1.fi/security/"
5SECTION = "network"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://COPYING;md5=279b4f5abb9c153c285221855ddb78cc \
8 file://README;beginline=1;endline=56;md5=e7d3dbb01f75f0b9799e192731d1e1ff \
9 file://wpa_supplicant/wpa_supplicant.c;beginline=1;endline=12;md5=0a8b56d3543498b742b9c0e94cc2d18b"
10DEPENDS = "dbus libnl"
11RRECOMMENDS_${PN} = "wpa-supplicant-passphrase wpa-supplicant-cli"
12
13PACKAGECONFIG ??= "gnutls"
14PACKAGECONFIG[gnutls] = ",,gnutls libgcrypt"
15PACKAGECONFIG[openssl] = ",,openssl"
16
17inherit pkgconfig systemd
18
19SYSTEMD_SERVICE_${PN} = "wpa_supplicant.service"
20SYSTEMD_AUTO_ENABLE = "disable"
21
22SRC_URI = "http://w1.fi/releases/wpa_supplicant-${PV}.tar.gz \
23 file://defconfig \
24 file://wpa-supplicant.sh \
25 file://wpa_supplicant.conf \
26 file://wpa_supplicant.conf-sane \
27 file://99_wpa_supplicant \
28 file://0001-replace-systemd-install-Alias-with-WantedBy.patch \
29 file://0001-AP-Silently-ignore-management-frame-from-unexpected-.patch \
30 file://0001-WPS-UPnP-Do-not-allow-event-subscriptions-with-URLs-.patch \
31 file://0002-WPS-UPnP-Fix-event-message-generation-using-a-long-U.patch \
32 file://0003-WPS-UPnP-Handle-HTTP-initiation-failures-for-events-.patch \
33 file://CVE-2021-0326.patch \
34 "
35SRC_URI[md5sum] = "2d2958c782576dc9901092fbfecb4190"
36SRC_URI[sha256sum] = "fcbdee7b4a64bea8177973299c8c824419c413ec2e3a95db63dd6a5dc3541f17"
37
38CVE_PRODUCT = "wpa_supplicant"
39
40S = "${WORKDIR}/wpa_supplicant-${PV}"
41
42PACKAGES_prepend = "wpa-supplicant-passphrase wpa-supplicant-cli "
43FILES_wpa-supplicant-passphrase = "${bindir}/wpa_passphrase"
44FILES_wpa-supplicant-cli = "${sbindir}/wpa_cli"
45FILES_${PN} += "${datadir}/dbus-1/system-services/* ${systemd_system_unitdir}/*"
46CONFFILES_${PN} += "${sysconfdir}/wpa_supplicant.conf"
47
48do_configure () {
49 ${MAKE} -C wpa_supplicant clean
50 install -m 0755 ${WORKDIR}/defconfig wpa_supplicant/.config
51
52 if echo "${PACKAGECONFIG}" | grep -qw "openssl"; then
53 ssl=openssl
54 elif echo "${PACKAGECONFIG}" | grep -qw "gnutls"; then
55 ssl=gnutls
56 fi
57 if [ -n "$ssl" ]; then
58 sed -i "s/%ssl%/$ssl/" wpa_supplicant/.config
59 fi
60
61 # For rebuild
62 rm -f wpa_supplicant/*.d wpa_supplicant/dbus/*.d
63}
64
65export EXTRA_CFLAGS = "${CFLAGS}"
66export BINDIR = "${sbindir}"
67
68do_compile () {
69 unset CFLAGS CPPFLAGS CXXFLAGS
70 sed -e "s:CFLAGS\ =.*:& \$(EXTRA_CFLAGS):g" -i ${S}/src/lib.rules
71 oe_runmake -C wpa_supplicant
72}
73
74do_install () {
75 install -d ${D}${sbindir}
76 install -m 755 wpa_supplicant/wpa_supplicant ${D}${sbindir}
77 install -m 755 wpa_supplicant/wpa_cli ${D}${sbindir}
78
79 install -d ${D}${bindir}
80 install -m 755 wpa_supplicant/wpa_passphrase ${D}${bindir}
81
82 install -d ${D}${docdir}/wpa_supplicant
83 install -m 644 wpa_supplicant/README ${WORKDIR}/wpa_supplicant.conf ${D}${docdir}/wpa_supplicant
84
85 install -d ${D}${sysconfdir}
86 install -m 600 ${WORKDIR}/wpa_supplicant.conf-sane ${D}${sysconfdir}/wpa_supplicant.conf
87
88 install -d ${D}${sysconfdir}/network/if-pre-up.d/
89 install -d ${D}${sysconfdir}/network/if-post-down.d/
90 install -d ${D}${sysconfdir}/network/if-down.d/
91 install -m 755 ${WORKDIR}/wpa-supplicant.sh ${D}${sysconfdir}/network/if-pre-up.d/wpa-supplicant
92 cd ${D}${sysconfdir}/network/ && \
93 ln -sf ../if-pre-up.d/wpa-supplicant if-post-down.d/wpa-supplicant
94
95 install -d ${D}/${sysconfdir}/dbus-1/system.d
96 install -m 644 ${S}/wpa_supplicant/dbus/dbus-wpa_supplicant.conf ${D}/${sysconfdir}/dbus-1/system.d
97 install -d ${D}/${datadir}/dbus-1/system-services
98 install -m 644 ${S}/wpa_supplicant/dbus/*.service ${D}/${datadir}/dbus-1/system-services
99
100 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
101 install -d ${D}/${systemd_unitdir}/system
102 install -m 644 ${S}/wpa_supplicant/systemd/*.service ${D}/${systemd_unitdir}/system
103 fi
104
105 install -d ${D}/etc/default/volatiles
106 install -m 0644 ${WORKDIR}/99_wpa_supplicant ${D}/etc/default/volatiles
107}
108
109pkg_postinst_wpa-supplicant () {
110 # If we're offline, we don't need to do this.
111 if [ "x$D" = "x" ]; then
112 killall -q -HUP dbus-daemon || true
113 fi
114
115}