summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/socat/socat_1.8.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/socat/socat_1.8.0.0.bb')
-rw-r--r--meta/recipes-connectivity/socat/socat_1.8.0.0.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/socat/socat_1.8.0.0.bb b/meta/recipes-connectivity/socat/socat_1.8.0.0.bb
new file mode 100644
index 0000000000..912605c95c
--- /dev/null
+++ b/meta/recipes-connectivity/socat/socat_1.8.0.0.bb
@@ -0,0 +1,53 @@
1SUMMARY = "Multipurpose relay for bidirectional data transfer"
2DESCRIPTION = "Socat is a relay for bidirectional data \
3transfer between two independent data channels."
4HOMEPAGE = "http://www.dest-unreach.org/socat/"
5
6SECTION = "console/network"
7
8LICENSE = "GPL-2.0-with-OpenSSL-exception"
9LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
10 file://README;beginline=241;endline=271;md5=338c05eadd013872abb1d6e198e10a3f"
11
12SRC_URI = "http://www.dest-unreach.org/socat/download/socat-${PV}.tar.bz2 \
13 file://0001-fix-compile-procan.c-failed.patch \
14"
15
16SRC_URI[sha256sum] = "e1de683dd22ee0e3a6c6bbff269abe18ab0c9d7eb650204f125155b9005faca7"
17
18inherit autotools
19
20EXTRA_AUTORECONF += "--exclude=autoheader"
21
22EXTRA_OECONF += "ac_cv_have_z_modifier=yes \
23 ac_cv_header_bsd_libutil_h=no \
24 sc_cv_termios_ispeed=no \
25 ${TERMBITS_SHIFTS} \
26"
27
28TERMBITS_SHIFTS ?= "sc_cv_sys_crdly_shift=9 \
29 sc_cv_sys_tabdly_shift=11 \
30 sc_cv_sys_csize_shift=4"
31
32TERMBITS_SHIFTS:powerpc = "sc_cv_sys_crdly_shift=12 \
33 sc_cv_sys_tabdly_shift=10 \
34 sc_cv_sys_csize_shift=8"
35
36TERMBITS_SHIFTS:powerpc64 = "sc_cv_sys_crdly_shift=12 \
37 sc_cv_sys_tabdly_shift=10 \
38 sc_cv_sys_csize_shift=8"
39
40PACKAGECONFIG:class-target ??= "tcp-wrappers readline openssl"
41PACKAGECONFIG ??= "readline openssl"
42PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
43PACKAGECONFIG[readline] = "--enable-readline,--disable-readline,readline"
44PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
45
46CFLAGS += "-fcommon"
47
48do_install:prepend () {
49 mkdir -p ${D}${bindir}
50 install -d ${D}${bindir} ${D}${mandir}/man1
51}
52
53BBCLASSEXTEND = "native nativesdk"