summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/socat/socat_1.7.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/socat/socat_1.7.3.2.bb')
-rw-r--r--meta/recipes-connectivity/socat/socat_1.7.3.2.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/socat/socat_1.7.3.2.bb b/meta/recipes-connectivity/socat/socat_1.7.3.2.bb
new file mode 100644
index 0000000000..4dcb7b4adc
--- /dev/null
+++ b/meta/recipes-connectivity/socat/socat_1.7.3.2.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Multipurpose relay for bidirectional data transfer"
2DESCRIPTION = "Socat is a relay for bidirectional data \
3transfer between two independent data channels."
4HOMEPAGE = "http://www.dest-unreach.org/socat/"
5
6SECTION = "console/network"
7
8DEPENDS = "openssl readline"
9
10LICENSE = "GPL-2.0+-with-OpenSSL-exception"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://README;beginline=257;endline=287;md5=338c05eadd013872abb1d6e198e10a3f"
13
14
15SRC_URI = "http://www.dest-unreach.org/socat/download/socat-${PV}.tar.bz2 \
16 file://Makefile.in-fix-for-parallel-build.patch \
17 file://0001-define-NETDB_INTERNAL-to-1-if-not-available.patch \
18 file://0001-Access-c_ispeed-and-c_ospeed-via-APIs.patch \
19"
20
21SRC_URI[md5sum] = "607a24c15bd2cb54e9328bfbbd3a1ae9"
22SRC_URI[sha256sum] = "e3561f808739383eb10fada1e5d4f26883f0311b34fd0af7837d0c95ef379251"
23
24inherit autotools
25
26EXTRA_AUTORECONF += "--exclude=autoheader"
27
28EXTRA_OECONF += "ac_cv_have_z_modifier=yes \
29 ac_cv_header_bsd_libutil_h=no \
30"
31
32PACKAGECONFIG_class-target ??= "tcp-wrappers"
33PACKAGECONFIG ??= ""
34PACKAGECONFIG[tcp-wrappers] = "--enable-libwrap,--disable-libwrap,tcp-wrappers"
35
36do_install_prepend () {
37 mkdir -p ${D}${bindir}
38 install -d ${D}${bindir} ${D}${mandir}/man1
39}
40
41BBCLASSEXTEND = "native nativesdk"