summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/resolvconf/resolvconf_1.72.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/resolvconf/resolvconf_1.72.bb')
-rw-r--r--meta/recipes-connectivity/resolvconf/resolvconf_1.72.bb22
1 files changed, 21 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/resolvconf/resolvconf_1.72.bb b/meta/recipes-connectivity/resolvconf/resolvconf_1.72.bb
index a96dbff949..4fe70f5216 100644
--- a/meta/recipes-connectivity/resolvconf/resolvconf_1.72.bb
+++ b/meta/recipes-connectivity/resolvconf/resolvconf_1.72.bb
@@ -23,7 +23,17 @@ do_compile () {
23} 23}
24 24
25do_install () { 25do_install () {
26 install -d ${D}${sysconfdir} ${D}${base_sbindir} ${D}${localstatedir}/volatile/run/resolvconf/interface 26 install -d ${D}${sysconfdir}/default/volatiles
27 echo "d root root 0755 ${localstatedir}/run/${BPN}/interface none" \
28 > ${D}${sysconfdir}/default/volatiles/99_resolvconf
29 if ${@base_contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
30 install -d ${D}${sysconfdir}/tmpfiles.d
31 echo "d /run/${BPN}/interface - - - -" \
32 > ${D}${sysconfdir}/tmpfiles.d/resolvconf.conf
33 fi
34 install -d ${D}${sysconfdir}/${BPN}
35 ln -snf ${localstatedir}/run/${BPN} ${D}${sysconfdir}/${BPN}/run
36 install -d ${D}${sysconfdir} ${D}${base_sbindir}
27 install -d ${D}${mandir}/man8 ${D}${docdir}/${P} 37 install -d ${D}${mandir}/man8 ${D}${docdir}/${P}
28 cp -pPR etc/* ${D}${sysconfdir}/ 38 cp -pPR etc/* ${D}${sysconfdir}/
29 chown -R root:root ${D}${sysconfdir}/ 39 chown -R root:root ${D}${sysconfdir}/
@@ -31,3 +41,13 @@ do_install () {
31 install -m 0644 README ${D}${docdir}/${P}/ 41 install -m 0644 README ${D}${docdir}/${P}/
32 install -m 0644 man/resolvconf.8 ${D}${mandir}/man8/ 42 install -m 0644 man/resolvconf.8 ${D}${mandir}/man8/
33} 43}
44
45pkg_postinst_${PN} () {
46 if [ -z "$D" ]; then
47 if command -v systemd-tmpfiles >/dev/null; then
48 systemd-tmpfiles --create
49 elif [ -e ${sysconfdir}/init.d/populate-volatile.sh ]; then
50 ${sysconfdir}/init.d/populate-volatile.sh update
51 fi
52 fi
53}