summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.1.1.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.1.1.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.1.1.bb b/meta/recipes-connectivity/openssl/openssl_1.1.1.bb
index 4516f61021..af9038abd5 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.1.1.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.1.1.bb
@@ -26,6 +26,9 @@ SRC_URI[sha256sum] = "2836875a0f89c03d0fdf483941512613a50cfb421d6fd94b9f41d7279d
26 26
27inherit lib_package multilib_header ptest 27inherit lib_package multilib_header ptest
28 28
29B = "${WORKDIR}/build"
30do_configure[cleandirs] = "${B}"
31
29#| ./libcrypto.so: undefined reference to `getcontext' 32#| ./libcrypto.so: undefined reference to `getcontext'
30#| ./libcrypto.so: undefined reference to `setcontext' 33#| ./libcrypto.so: undefined reference to `setcontext'
31#| ./libcrypto.so: undefined reference to `makecontext' 34#| ./libcrypto.so: undefined reference to `makecontext'
@@ -107,7 +110,7 @@ do_configure () {
107 # WARNING: do not set compiler/linker flags (-I/-D etc.) in EXTRA_OECONF, as they will fully replace the 110 # WARNING: do not set compiler/linker flags (-I/-D etc.) in EXTRA_OECONF, as they will fully replace the
108 # environment variables set by bitbake. Adjust the environment variables instead. 111 # environment variables set by bitbake. Adjust the environment variables instead.
109 PERL5LIB="${S}/external/perl/Text-Template-1.46/lib/" \ 112 PERL5LIB="${S}/external/perl/Text-Template-1.46/lib/" \
110 perl ./Configure ${EXTRA_OECONF} ${PACKAGECONFIG_CONFARGS} --prefix=$useprefix --openssldir=${libdir}/ssl-1.1 --libdir=${libdir} $target 113 perl ${S}/Configure ${EXTRA_OECONF} ${PACKAGECONFIG_CONFARGS} --prefix=$useprefix --openssldir=${libdir}/ssl-1.1 --libdir=${libdir} $target
111} 114}
112 115
113do_install () { 116do_install () {
@@ -151,9 +154,11 @@ do_install_append_class-nativesdk () {
151} 154}
152 155
153do_install_ptest () { 156do_install_ptest () {
154 cp ${B}/Configure ${B}/configdata.pm ${D}${PTEST_PATH} 157 # Prune the build tree
155 # TODO fuzz needs to be pruned of non-binaries 158 rm -f ${B}/fuzz/*.* ${B}/test/*.*
156 cp -r ${B}/external ${B}/test ${B}/fuzz ${B}/util ${D}${PTEST_PATH} 159
160 cp ${S}/Configure ${B}/configdata.pm ${D}${PTEST_PATH}
161 cp -r ${S}/external ${B}/test ${S}/test ${B}/fuzz ${S}/util ${B}/util ${D}${PTEST_PATH}
157 162
158 # For test_shlibload 163 # For test_shlibload
159 ln -s ${libdir}/libcrypto.so.1.1 ${D}${PTEST_PATH}/libcrypto.so 164 ln -s ${libdir}/libcrypto.so.1.1 ${D}${PTEST_PATH}/libcrypto.so
@@ -161,7 +166,7 @@ do_install_ptest () {
161 166
162 install -d ${D}${PTEST_PATH}/apps 167 install -d ${D}${PTEST_PATH}/apps
163 ln -s ${bindir}/openssl ${D}${PTEST_PATH}/apps 168 ln -s ${bindir}/openssl ${D}${PTEST_PATH}/apps
164 install -m644 ${B}/apps/*.pem ${B}/apps/*.srl ${B}/apps/openssl.cnf ${D}${PTEST_PATH}/apps 169 install -m644 ${S}/apps/*.pem ${S}/apps/*.srl ${S}/apps/openssl.cnf ${D}${PTEST_PATH}/apps
165 install -m755 ${B}/apps/CA.pl ${D}${PTEST_PATH}/apps 170 install -m755 ${B}/apps/CA.pl ${D}${PTEST_PATH}/apps
166 171
167 install -d ${D}${PTEST_PATH}/engines 172 install -d ${D}${PTEST_PATH}/engines