summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/openssl/openssl_1.0.2o.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/openssl/openssl_1.0.2o.bb')
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.2o.bb9
1 files changed, 4 insertions, 5 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.2o.bb b/meta/recipes-connectivity/openssl/openssl_1.0.2o.bb
index 9bc9e64c12..d9e9c8408e 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.0.2o.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.2o.bb
@@ -63,6 +63,9 @@ UPSTREAM_CHECK_REGEX = "openssl-(?P<pver>1\.0.+)\.tar"
63inherit pkgconfig siteinfo multilib_header ptest relative_symlinks 63inherit pkgconfig siteinfo multilib_header ptest relative_symlinks
64 64
65PACKAGECONFIG ?= "cryptodev-linux" 65PACKAGECONFIG ?= "cryptodev-linux"
66PACKAGECONFIG_class-native = ""
67PACKAGECONFIG_class-nativesdk = ""
68
66PACKAGECONFIG[perl] = ",,," 69PACKAGECONFIG[perl] = ",,,"
67PACKAGECONFIG[cryptodev-linux] = "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS,,cryptodev-linux" 70PACKAGECONFIG[cryptodev-linux] = "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS,,cryptodev-linux"
68 71
@@ -88,10 +91,6 @@ CFLAG = "${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'le', '-DL_ENDIAN', '-DB
88# (and it causes issues with SELinux) 91# (and it causes issues with SELinux)
89CFLAG += "-Wa,--noexecstack" 92CFLAG += "-Wa,--noexecstack"
90 93
91# For target side versions of openssl enable support for OCF Linux driver
92# if they are available.
93CFLAG += "-DHAVE_CRYPTODEV -DUSE_CRYPTODEV_DIGESTS"
94
95CFLAG_append_class-native = " -fPIC" 94CFLAG_append_class-native = " -fPIC"
96 95
97do_configure_prepend_darwin () { 96do_configure_prepend_darwin () {
@@ -208,7 +207,7 @@ do_configure () {
208 useprefix=/ 207 useprefix=/
209 fi 208 fi
210 libdirleaf="$(echo ${libdir} | sed s:$useprefix::)" 209 libdirleaf="$(echo ${libdir} | sed s:$useprefix::)"
211 perl ./Configure ${EXTRA_OECONF} shared --prefix=$useprefix --openssldir=${libdir}/ssl --libdir=$libdirleaf $target 210 perl ./Configure ${EXTRA_OECONF} ${PACKAGECONFIG_CONFARGS} shared --prefix=$useprefix --openssldir=${libdir}/ssl --libdir=$libdirleaf $target
212} 211}
213 212
214do_compile_prepend_class-target () { 213do_compile_prepend_class-target () {