summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/ofono/ofono_2.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/ofono/ofono_2.8.bb')
-rw-r--r--meta/recipes-connectivity/ofono/ofono_2.8.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/ofono/ofono_2.8.bb b/meta/recipes-connectivity/ofono/ofono_2.8.bb
new file mode 100644
index 0000000000..809485d421
--- /dev/null
+++ b/meta/recipes-connectivity/ofono/ofono_2.8.bb
@@ -0,0 +1,48 @@
1SUMMARY = "open source telephony"
2DESCRIPTION = "oFono is a stack for mobile telephony devices on Linux. oFono supports speaking to telephony devices through specific drivers, or with generic AT commands."
3HOMEPAGE = "http://www.ofono.org"
4BUGTRACKER = "https://01.org/jira/browse/OF"
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
7 file://src/ofono.h;beginline=1;endline=6;md5=13e42133935ceecfc9bcb547f256e277"
8DEPENDS = "dbus glib-2.0 udev mobile-broadband-provider-info ell"
9
10SRC_URI = "\
11 ${KERNELORG_MIRROR}/linux/network/${BPN}/${BP}.tar.xz \
12 file://ofono \
13"
14SRC_URI[sha256sum] = "b5aef455b3a374ce43bad43c2ade9d0430d9c0d28952385c44ac7d0dc933bbb8"
15
16inherit autotools pkgconfig update-rc.d systemd gobject-introspection-data
17
18INITSCRIPT_NAME = "ofono"
19INITSCRIPT_PARAMS = "defaults 22"
20SYSTEMD_SERVICE:${PN} = "ofono.service"
21
22PACKAGECONFIG ??= "\
23 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
24 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
25"
26PACKAGECONFIG[systemd] = "--with-systemdunitdir=${systemd_system_unitdir}/,--with-systemdunitdir="
27PACKAGECONFIG[bluez] = "--enable-bluetooth, --disable-bluetooth, bluez5"
28
29EXTRA_OECONF += "--enable-test --enable-external-ell"
30
31do_install:append() {
32 install -d ${D}${sysconfdir}/init.d/
33 install -m 0755 ${UNPACKDIR}/ofono ${D}${sysconfdir}/init.d/ofono
34}
35
36PACKAGES =+ "${PN}-tests"
37
38FILES:${PN} += "${systemd_unitdir}"
39FILES:${PN}-tests = "${libdir}/${BPN}/test"
40
41RDEPENDS:${PN} += "dbus"
42RDEPENDS:${PN}-tests = "\
43 python3-core \
44 python3-dbus \
45 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'python3-pygobject', '', d)} \
46"
47
48RRECOMMENDS:${PN} += "kernel-module-tun mobile-broadband-provider-info"