summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/ofono/ofono_2.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/ofono/ofono_2.4.bb')
-rw-r--r--meta/recipes-connectivity/ofono/ofono_2.4.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/ofono/ofono_2.4.bb b/meta/recipes-connectivity/ofono/ofono_2.4.bb
new file mode 100644
index 0000000000..dae5cc3c25
--- /dev/null
+++ b/meta/recipes-connectivity/ofono/ofono_2.4.bb
@@ -0,0 +1,55 @@
1SUMMARY = "open source telephony"
2DESCRIPTION = "oFono is a stack for mobile telephony devices on Linux. oFono supports speaking to telephony devices through specific drivers, or with generic AT commands."
3HOMEPAGE = "http://www.ofono.org"
4BUGTRACKER = "https://01.org/jira/browse/OF"
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
7 file://src/ofono.h;beginline=1;endline=20;md5=3ce17d5978ef3445def265b98899c2ee"
8DEPENDS = "dbus glib-2.0 udev mobile-broadband-provider-info ell"
9
10SRC_URI = "\
11 ${KERNELORG_MIRROR}/linux/network/${BPN}/${BP}.tar.xz \
12 file://ofono \
13 file://0001-mbim-add-an-optional-TEMP_FAILURE_RETRY-macro-copy.patch \
14 file://0002-mbim-Fix-build-with-ell-0.39-by-restoring-unlikely-m.patch \
15"
16SRC_URI[sha256sum] = "93580adc1afd1890dc516efb069de0c5cdfef014415256ddfb28ab172df2d11d"
17
18inherit autotools pkgconfig update-rc.d systemd gobject-introspection-data
19
20INITSCRIPT_NAME = "ofono"
21INITSCRIPT_PARAMS = "defaults 22"
22SYSTEMD_SERVICE:${PN} = "ofono.service"
23
24PACKAGECONFIG ??= "\
25 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
26 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
27"
28PACKAGECONFIG[systemd] = "--with-systemdunitdir=${systemd_system_unitdir}/,--with-systemdunitdir="
29PACKAGECONFIG[bluez] = "--enable-bluetooth, --disable-bluetooth, bluez5"
30
31EXTRA_OECONF += "--enable-test --enable-external-ell"
32
33do_configure:prepend() {
34 bbnote "Removing bundled ell from ${S}/ell to prevent including it"
35 rm -rf ${S}/ell
36}
37
38do_install:append() {
39 install -d ${D}${sysconfdir}/init.d/
40 install -m 0755 ${WORKDIR}/ofono ${D}${sysconfdir}/init.d/ofono
41}
42
43PACKAGES =+ "${PN}-tests"
44
45FILES:${PN} += "${systemd_unitdir}"
46FILES:${PN}-tests = "${libdir}/${BPN}/test"
47
48RDEPENDS:${PN} += "dbus"
49RDEPENDS:${PN}-tests = "\
50 python3-core \
51 python3-dbus \
52 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'python3-pygobject', '', d)} \
53"
54
55RRECOMMENDS:${PN} += "kernel-module-tun mobile-broadband-provider-info"