summaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/nfs-utils/nfs-utils_2.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/nfs-utils/nfs-utils_2.3.1.bb')
-rw-r--r--meta/recipes-connectivity/nfs-utils/nfs-utils_2.3.1.bb151
1 files changed, 151 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/nfs-utils/nfs-utils_2.3.1.bb b/meta/recipes-connectivity/nfs-utils/nfs-utils_2.3.1.bb
new file mode 100644
index 0000000000..6390c324f8
--- /dev/null
+++ b/meta/recipes-connectivity/nfs-utils/nfs-utils_2.3.1.bb
@@ -0,0 +1,151 @@
1SUMMARY = "userspace utilities for kernel nfs"
2DESCRIPTION = "The nfs-utils package provides a daemon for the kernel \
3NFS server and related tools."
4HOMEPAGE = "http://nfs.sourceforge.net/"
5SECTION = "console/network"
6
7LICENSE = "MIT & GPLv2+ & BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=95f3a93a5c3c7888de623b46ea085a84"
9
10# util-linux for libblkid
11DEPENDS = "libcap libnfsidmap libevent util-linux sqlite3 libtirpc"
12RDEPENDS_${PN} = "${PN}-client bash"
13RRECOMMENDS_${PN} = "kernel-module-nfsd"
14
15inherit useradd
16
17USERADD_PACKAGES = "${PN}-client"
18USERADD_PARAM_${PN}-client = "--system --home-dir /var/lib/nfs \
19 --shell /bin/false --user-group rpcuser"
20
21SRC_URI = "${KERNELORG_MIRROR}/linux/utils/nfs-utils/${PV}/nfs-utils-${PV}.tar.xz \
22 file://nfsserver \
23 file://nfscommon \
24 file://nfs-utils.conf \
25 file://nfs-server.service \
26 file://nfs-mountd.service \
27 file://nfs-statd.service \
28 file://proc-fs-nfsd.mount \
29 file://nfs-utils-Do-not-pass-CFLAGS-to-gcc-while-building.patch \
30 file://nfs-utils-debianize-start-statd.patch \
31 file://bugfix-adjust-statd-service-name.patch \
32 file://nfs-utils-musl-limits.patch \
33"
34
35SRC_URI_append_libc-musl = " file://nfs-utils-musl-res_querydomain.patch"
36
37SRC_URI[md5sum] = "d77b182a9ee396aa6221ac2401ad7046"
38SRC_URI[sha256sum] = "96d06b5a86b185815760d8f04c34fdface8fa8b9949ff256ac05c3ebc08335a5"
39
40# Only kernel-module-nfsd is required here (but can be built-in) - the nfsd module will
41# pull in the remainder of the dependencies.
42
43INITSCRIPT_PACKAGES = "${PN} ${PN}-client"
44INITSCRIPT_NAME = "nfsserver"
45INITSCRIPT_PARAMS = "defaults"
46INITSCRIPT_NAME_${PN}-client = "nfscommon"
47INITSCRIPT_PARAMS_${PN}-client = "defaults 19 21"
48
49inherit autotools-brokensep update-rc.d systemd pkgconfig
50
51SYSTEMD_PACKAGES = "${PN} ${PN}-client"
52SYSTEMD_SERVICE_${PN} = "nfs-server.service nfs-mountd.service"
53SYSTEMD_SERVICE_${PN}-client = "nfs-statd.service"
54
55# --enable-uuid is need for cross-compiling
56EXTRA_OECONF = "--with-statduser=rpcuser \
57 --enable-mountconfig \
58 --enable-libmount-mount \
59 --enable-uuid \
60 --disable-gss \
61 --disable-nfsdcltrack \
62 --with-statdpath=/var/lib/nfs/statd \
63 "
64
65PACKAGECONFIG ??= "tcp-wrappers \
66 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
67"
68PACKAGECONFIG_remove_libc-musl = "tcp-wrappers"
69PACKAGECONFIG[tcp-wrappers] = "--with-tcp-wrappers,--without-tcp-wrappers,tcp-wrappers"
70PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
71# libdevmapper is available in meta-oe
72PACKAGECONFIG[nfsv41] = "--enable-nfsv41,--disable-nfsv41,libdevmapper"
73# keyutils is available in meta-security
74PACKAGECONFIG[nfsv4] = "--enable-nfsv4,--disable-nfsv4,keyutils"
75
76PACKAGES =+ "${PN}-client ${PN}-mount ${PN}-stats"
77
78CONFFILES_${PN}-client += "${localstatedir}/lib/nfs/etab \
79 ${localstatedir}/lib/nfs/rmtab \
80 ${localstatedir}/lib/nfs/xtab \
81 ${localstatedir}/lib/nfs/statd/state \
82 ${sysconfdir}/nfsmount.conf"
83
84FILES_${PN}-client = "${sbindir}/*statd \
85 ${sbindir}/rpc.idmapd ${sbindir}/sm-notify \
86 ${sbindir}/showmount ${sbindir}/nfsstat \
87 ${localstatedir}/lib/nfs \
88 ${sysconfdir}/nfs-utils.conf \
89 ${sysconfdir}/nfsmount.conf \
90 ${sysconfdir}/init.d/nfscommon \
91 ${systemd_unitdir}/system/nfs-statd.service"
92RDEPENDS_${PN}-client = "${PN}-mount rpcbind"
93
94FILES_${PN}-mount = "${base_sbindir}/*mount.nfs*"
95
96FILES_${PN}-stats = "${sbindir}/mountstats ${sbindir}/nfsiostat"
97RDEPENDS_${PN}-stats = "python3-core"
98
99FILES_${PN} += "${systemd_unitdir}"
100
101do_configure_prepend() {
102 sed -i -e 's,sbindir = /sbin,sbindir = ${base_sbindir},g' \
103 ${S}/utils/mount/Makefile.am
104
105 sed -i -e 's,sbindir = /sbin,sbindir = ${base_sbindir},g' \
106 ${S}/utils/osd_login/Makefile.am
107}
108
109# Make clean needed because the package comes with
110# precompiled 64-bit objects that break the build
111do_compile_prepend() {
112 make clean
113}
114
115do_install_append () {
116 install -d ${D}${sysconfdir}/init.d
117 install -m 0755 ${WORKDIR}/nfsserver ${D}${sysconfdir}/init.d/nfsserver
118 install -m 0755 ${WORKDIR}/nfscommon ${D}${sysconfdir}/init.d/nfscommon
119
120 install -m 0755 ${WORKDIR}/nfs-utils.conf ${D}${sysconfdir}
121 install -m 0755 ${S}/utils/mount/nfsmount.conf ${D}${sysconfdir}
122
123 install -d ${D}${systemd_unitdir}/system
124 install -m 0644 ${WORKDIR}/nfs-server.service ${D}${systemd_unitdir}/system/
125 install -m 0644 ${WORKDIR}/nfs-mountd.service ${D}${systemd_unitdir}/system/
126 install -m 0644 ${WORKDIR}/nfs-statd.service ${D}${systemd_unitdir}/system/
127 sed -i -e 's,@SBINDIR@,${sbindir},g' \
128 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
129 ${D}${systemd_unitdir}/system/*.service
130 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
131 install -m 0644 ${WORKDIR}/proc-fs-nfsd.mount ${D}${systemd_unitdir}/system/
132 install -d ${D}${systemd_unitdir}/system/sysinit.target.wants/
133 ln -sf ../proc-fs-nfsd.mount ${D}${systemd_unitdir}/system/sysinit.target.wants/proc-fs-nfsd.mount
134 fi
135
136 # kernel code as of 3.8 hard-codes this path as a default
137 install -d ${D}/var/lib/nfs/v4recovery
138
139 # chown the directories and files
140 chown -R rpcuser:rpcuser ${D}${localstatedir}/lib/nfs/statd
141 chmod 0644 ${D}${localstatedir}/lib/nfs/statd/state
142
143 # the following are built by CC_FOR_BUILD
144 rm -f ${D}${sbindir}/rpcdebug
145 rm -f ${D}${sbindir}/rpcgen
146 rm -f ${D}${sbindir}/locktest
147
148 # Make python tools use python 3
149 sed -i -e '1s,#!.*python.*,#!${bindir}/python3,' ${D}${sbindir}/mountstats ${D}${sbindir}/nfsiostat
150
151}